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Tárgyalt ismeretkörök

1. Bevezetés – Beágyazott rendszerek, FPGA-k, Digilent
ZYBO fejlesztő kártyák és eszközök

2. Beágyazott Rendszer fejlesztő szoftverkörnyezet 
(Xilinx Vivado Embedded Development) áttekintése

3. Beágyazott alap tesztrendszer (BSB - Base System 
Builder and Board Bring-Up) összeállítása

4. Perifériák hozzáadása (IP adatbázisból) az összeállított 
beágyazott alaprendszerhez. Saját periféria 
hozzáadása az összeállított beágyazott 
alaprendszerhez

5. Szoftver alkalmazások fejlesztése, tesztelése: PMOD 
TMP hőmérséklet mérő
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A feladat megoldásának lépései

• Az előző (04. fólia) ismeretkör elsajátítása során létrehozott
– File -> Project -> Save As…
– Alternatív módszer lehet: projekt archiválása (LAB02B → LAB03

néven), majd pedig a \LAB03 megnyitása Vivado-ban,

• Az IP katalógusból kiválasztott I2C periféria integrálása és
összekötése az alaprendszerrel,

• Külső I2C portok létrehozása (.XDC),

• Egy Periféria teszt-alkalmazás (PMOD_Test) készítése az
SDK-környezetben,

• A FW+SW tervek teszt verifikálása a Digilent ZyBo kártyán.
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A bővítendő tesztrendszer

PS oldal:
• ARM hard-processzor mag
• belső OnChip-RAM vezérlő
• RS232 soros interfész
• külső DDR3 memória vezérlő
• (I2C vezérlő opcionális)
• Timer / interrupt vezérlő (ARM)
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PL oldal:
• LAB02_A: GPIO bemenetek

– PBSs: Push Button (nyomógomb kezelő)
– DIPs: Switches (kapcsoló kezelő)

• LAB02_B: GPIO kimenet
– LEDs: LED kijelző

• LAB03: I2C vezérlős hőmérsékletmérő modul
(PMOD_TMP2)

– ARM PS/ vagy PL oldalra is csatlakoztatható
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Irodalmi háttér

• Digilent PMOD TMP2 hőmérséklet szenzor modul 
(I2C):
–  https://store.digilentinc.com/pmod-tmp2-temperature-sensor/

–  https://reference.digilentinc.com/reference/pmod/pmodtmp2/reference-manual

• Analog Devices ADT7420 hőmérséklet érzékelő IC:
–  http://www.analog.com/media/en/technical-documentation/data-sheets/ADT7420.pdf

• Analog Devices – Digilent közös Wiki oldala:
–  http://wiki.analog.com/resources/alliances/digilent

Referencia terv FPGA-ra (SW driver-ekkel)!

–  http://wiki.analog.com/resources/fpga/xilinx/pmod/adt7420

• I2C szabványról általánosan:
–  Dr. Fodor Attila, Dr. Vörösházi Zsolt: Beágyazott rendszerek, TÁMOP 4.1.2 

(PE MIK, Villamosmérnöki és Információs Rendszerek Tanszék) 2011. 
http://tananyagfejlesztes.mik.uni-pannon.hu/

–  I2C Wikipedia: https://en.wikipedia.org/wiki/I%C2%B2C
6



Digilent PMOD_TMP2

• I2C alapú hőmérséklet érzékelő és 
hőfokszabályzó periféria modul 
– TA= −40°C  … +150°C,
– max. 16-bit felbontásig skálázható,
– Átlagos pontossága jobb, mint 0.25 °C,

• 13 = 9+4 bites módban: 1/24 = 0.0625 °C,
• 16 = 9+7 bites módban: 1/27 = 0.0078 °C,

– I2C interfész, 4 választható (jumper) I2C címmel (A1-A0)
• „Daisy Chain” lehetőség (7/10 bites címzés)

– Folyamatos konverzió 240ms-ként,
– Programozható küszöbértékek (max/min - CT), külső lábak, 

mint threshold (INT),
– 3.3V vagy 5V interfész támogatás,
– Kalibrálást nem igényel!
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ADT 7420

• Az áramkör blokkszintű kapcsolási rajza:

• PMOD_TMP2 jelei     /    választható I2C címek:
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Philips I2C  szabványról (1982)
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1. Data Transfer is initiated with a START bit (S) 
signaled by SDA being pulled low while SCL stays 
high (pull-down).
2. SDA sets the 1st data bit level while keeping SCL 
low (during blue bar time) .
3.The data is sampled (received) when SCL rises 
(green) for the first bit (B1).
4. This process repeats, SDA transitioning until SCL 
is low again, and the data being read while SCL is 
high (B2, Bn).
5. A STOP bit (P) is signaled when SDA is pulled 
high while SCL is high.

Forrás: https://en.wikipedia.org/wiki/I%C2%B2C

„Master write(0) to / read(1) from the Slave”



I2C vezérlő hozzáadása és összekötése az alaprendszerrel I.
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• I2C vezérlő csatlakoztatására két lehetőség van  
– a.) PL-oldali AXI_I2C IP mag hozzáadása, vagy 
– b.) PS-oldali PS_I2C0/1 periféria vezérlő engedélyezése Zynq alrendszerben.

• Adjunk a processzor rendszerhez egy   AXI_IIC perifériát a Block Diagram 
segítségével (IP katalógusból)

2

1

3

4
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AXI IIC periféria hozzáadása az alaprendszerhez II. 

1

Dupla kattintással vizsgáljuk meg az AXI_IIC-t:
(minden maradjon alap beállításon)



Alternatív megoldás: PS I2C

• Nem ezt használjuk, ez csak lehetőség.

• PL (FPGA) oldali I2C blokkot használjuk!
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AXI GPIO-k bekötése (autorouter)
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Block design – teljes nézet
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• Block Design -> „Address Editor” nézet kiválasztása

• „Map”-eletlen IP perifériák memória-címtartományhoz
rendelése:
– a.) automatikusan - címgenerálással vs. b.) manuálisan

15

AXI IIC - Memória címtartományok beállítása

1

2

*Címtartományoknak 2^n méretűeknek kell lennie 
és nem lapolódhatnak át! 
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AXI GPIO - Külső portok hozzárendelése

Az AXI_IIC példányhoz hozzá kell még kapcsolni a ZyBo kártyán található (PMOD
JE 3,4 jeleket) az FPGA (PL-oldali) lábakhoz:

1.) Az AXI_IIC port-jait a külső fizikai FPGA lábakra (pin) is kell kötni,

2.) Ha kell, a külső portok neveit is definiáljuk (pl: „_pin” végződésűre), majd

3.) Az <system>.XDC fájl-ban meg kell majd adni az adott FPGA pin azonosítóját.

1

3

2



Block Design – Layout szintézis
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• Ezek után egy-egy a Block Design-t frissíteni kell:

– Regenerate Layout

– Validate Design (DRC)

– Flow Navigator -> Run Synthesis

• Majd - Open Synthesized Design , OK

• Utolsó lépésként a külső porthoz (iic_pin) hozzá 
kell rendelni az FPGA IO lábakat!

– Layout menü -> I/O Planning layout nézet



IO planning – hibás lábkiosztás

• Amennyiben az előző lépésben nem a szintetizált 
tervet nyitjuk meg, hanem elindítjuk a „Run

Implementation”-t akkor az alábbi hibaüzenetet 
kapjuk:

• Oka: a Vivado megpróbálja elhelyezni a két I2C jelet.

– Hibás pin location-t és IO Standard-et rendelne (LVCMOS 
1.8V) hozzá. 18



ZyBo - PMOD konnektorok

19SCLSDA
https://www.xilinx.com/support/documentation/university/XUP%20Boards/XUPZYBO/documentation/ZYBO_RM_B_V6.pdf



IO planning – helyes lábkiosztás I.
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Végül  File -> Save Constraints vagy CTRL+S. Ezután rákérdez az XDC file elmentésére. 
Adjunk neki nevet:  pl.  „lab03.xdc” 

1 2 3 4

• a.) Egyik lehetőség az I/O planning használata (GUI)



IO planning – helyes lábkiosztás II.

• b.) Másik lehetőség az .xdc manuális szerkesztése
– File -> Add Sources… -> Add or Create constraints
– Create File 
– Adjunk neki nevet:  pl.  „lab03.xdc”

21

1

Végül  File -> Save Constraints vagy CTRL+S. Ezután rákérdez az XDC file 
elmentésére. 

2



• Flow Navigator menü → Run Implementation

– Kiszűri az esetleges elkötéseket, hibákat,

– Figyelmeztető (warning) jellegű üzenetek 
megengedettek (implementálható a terv),

– Legtöbb lebegő (floating) vezetékkel sem kell 
foglalkozni (pl. Peripheral Reset, stb).

– Miközben dolgozik – hosszabb idő - érdemes 
megnézni a fordítási riportokat!

Ezután indítható el a Bitstream generálás.

• Flow Navigator → Generate Bitstream.

22

Implementáció és bitstream generálás



SZOFTVER TESZT ALKALMAZÁS 
ÖSSZEÁLLÍTÁSA (PMOD_TMP2)

Xilinx Vivado SDK
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SDK – alkalmazás-fejlesztés általános lépései

1. Vivado projekt létrehozása, majd Export → SDK,

2. Új, vagy C/C++ template-ből generálható alkalmazás 
létrehozása ( TestApp PMOD alkalmazás ):

a) BSP (Board Support Package) generálása és fordítása,

b) Linker Script generálása (memória szekciók megadása, .ld),

c) SW alkalmazáskód megírása/generálása, és fordítása. (zip!)

3. Soros terminál beállítása (USB-soros port beállítása),

4. JTAG-USB programozó csatlakoztatása és beállítása,

5. FPGA konfigurálása!! ( .bit, mivel PL oldal is használt)

6. ‚debug’ – hardveres hibakeresés beállítása

7. Debug (breakpoint-ok beszúrása, léptetés, stb.)
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Export HW -> Vivado SDK
• File -> Export 

-> Export 
hardware 

• File -> Launch 
SDK, OK.
– Vivado SDK 

indítása a 
keretrendsze
rből (ezt 
kívülről indítva 
is meg lehetne 
tenni)

25

!

!



Vivado SDK GUI
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.hdf = Hardware description file = hardver konfigurációs csomag file. 
(Valójában egy zip, amely két leíró xml-t tartalmaz!) Ebből olvassa ki az SDK a beállításokat.

!



• 1.) A Launch SDK - Choose Location…
opciójával válasszuk ki a
<project_dir>/LAB03/ → majd kattintsunk
az OK-ra.

• 2.) Az SDK-ban: File → New → Board Support
Package → kattintsunk a Finish-re.

– Új BSP neve standalone_bsp_0 is maradhat,

– Hagyjunk mindent alap értéken.

27

Tesztalkalmazás (TestApp) készítése I.



• Software Platform Settings
– Operációs rendszer kiválasztása: standalone vs. xilkernel (esetleg 3rd Party OS)
– Rendelkezésre álló könyvtári függvények (lib) kiválasztása

28

Tesztalkalmazás (TestApp) készítése II./a
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Tesztalkalmazás (TestApp) készítése II./b



• Új projekt alkalmazás létrehozása 
(File –> New –> Application Project)

30

Tesztalkalmazás (TestApp) készítése III.

1

2
3
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1

2

3

Tesztalkalmazás (TestApp) készítése IV.



Forrás fájl(ok) importálása:   TestApp/src kijelölése!

• File -> Import … -> General -> Archive File-> NEXT!

32

1

2

Tesztalkalmazás (TestApp) készítése V.

BER_PmodTMP2_DriverFiles.zip * -ből hozzáadni:
- ADT7420.c / .h
- I2c.c / .h
- Main.c

* Tárgy oldaláról letölthető: BER_PmodTMP2_DriverFiles.zip

• Linker script generálása (.ld): OnChip RAM vs. külső MEM.
• SW alkalmazás fordítása (.elf)
• Tesztverifikáció: bitfile generálás + tesztelés FPGA-n.
*Megjegyzés: az i2c.c és i2.h fájlok az Analog Devices támogató csomagjából lettek felhasználva. Alternatív 
megoldásként a Xilinx iic.c és iic.h fájlokat is használhatjuk:
Lásd: <Xilinx install_dir>/…/sw/XilinxProcessorIPLib/drivers/iic_vX_YZ_a/doc/html/api/index.html

3



TestApp forráskód hibáinak javítása

1.) 

– Megoldás: adjuk meg az XPAR_AXI_IIC_BASEADDR #define
helyes nevét az xparameters.h file alapján

2.) 

– Megoldás: nézzük meg a ADT7420_IIC_ADDR helyes címét 
(korábbi fólia, v. kártya adatlap)

3.)

– Megoldás: keressünk ilyen nevű define-t az ADT7240.h file-
ban. 

33



Kérdés:

• Mekkora a letöltendő .elf file mérete?

• Megoldás: 

34

'Invoking: ARM Print Size'

arm-xilinx-eabi-size TestApp.elf |tee

"TestApp.elf.size"

text   data bss dec    hexfilename

27780   1160  22580  51520 c940TestApp.elf

'Finished building: TestApp.elf.size'



Teszt verifikáció I.

35

• Kártya helyes csatlakoztatása PMOD JE-re.

SCLSDA



Teszt verifikáció II.

• 1.) Digilent PMOD_TMP2 hőmérséklet mérő kártya megfelelő 
illesztése a Digilent ZyBo kártyához:
– Standard JE PMOD foglalat felső sorának jobbról 3-4-es lábaira (SCL – SDA)

– PMOD_TMP2-es kártyán a JP1/JP2 jumperek rövidre zártak? (A0/A1 címek 
kiosztása ennek megfelelően !!)

• 2.) A JTAG-USB programozó/táp (USB-soros port) 
csatlakoztatása a kártyához és a számítógéphez,

• 3.) Digilent ZyBo kártya bekapcsolása,

• 4.) Xilinx Tools → Program FPGA
– .bit  fájl kiválasztása,

– FPGA programozása,

• 5.) Debug konfiguráció: környezet beállítása és indítása:

– Consol-ra az USB soros port beállítása (COMx),

– Debug config-ban megadható akár az FPGA .bit file 
konfigurációja is (Entire reset).

36



Teszt verifikáció III.
• A forráskódból a következő rész felel az aktuális 

hőmérséklet kiíratásáért:
– Display_Temp(ADT7420_ReadTemp());

– Javaslat: tegyük a függvényt végtelen ciklusba a folyamatos kiíratáshoz.
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Eredmény (debug log)
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ID Register = 0xCB
Revision ID = 3
Manufacture ID = 25
-----------------------------------------
raw temp data: 456 -> Converted temp data T = 28.500 C
raw temp data: 456 -> Converted temp data T = 28.500 C
…

• Készítsük el annak Debug Configuration-ját, majd Debug-oljuk az
alkalmazást.


