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Tárgyalt ismeretkörök

1. Bevezetés – Beágyazott rendszerek, FPGA-k, Digilent
ZYBO fejlesztő kártyák és eszközök

2. Beágyazott Rendszer fejlesztő szoftverkörnyezet 
(Xilinx Vivado Embedded Development) áttekintése

3. Beágyazott alap tesztrendszer (BSB - Base System 
Builder and Board Bring-Up) összeállítása

4. Perifériák hozzáadása (IP adatbázisból) az összeállított 
beágyazott alaprendszerhez. Saját periféria 
hozzáadása az összeállított beágyazott 
alaprendszerhez

5. Szoftver alkalmazások fejlesztése, tesztelése: PMOD 
TMP hőmérséklet mérő

6. XADC – Xilinx AD converter, mint System Monitor. 
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Irodalomjegyzék

•  XADC - Xilinx Analog-Digital Converter:
https://www.xilinx.com/support/documentation/user_guides/ug480_7Series_XADC.pdf

•  Vivado – AXI XADC IP leírása
https://www.xilinx.com/products/intellectual-property/axi_xadc.html

•  XADC Wizard (paraméterezhetőség):
https://www.xilinx.com/support/documentation/ip_documentation/xadc_wiz/v3_3/pg091-xadc-wiz.pdf

•  XADC Use-cases:
https://www.xilinx.com/support/documentation/application_notes/xapp795-driving-xadc.pdf

•  Adam Taylor – MicroZed Chronicles Part 7-8:
Part7: https://forums.xilinx.com/t5/Xcell-Daily-Blog/Getting-the-XADC-Running-on-the-MicroZed-Adam-
Taylor-s-MicroZed/ba-p/380989

Part-8: https://forums.xilinx.com/t5/Xcell-Daily-Blog/MicroZed-XADC-Software-Adam-Taylor-s-
MicroZed-Chronicles-Part-8/ba-p/383861
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ADC – Analóg/Digitális konverzió

• Milyen lehetőségek vannak analóg jelek 

feldolgozására FPGA-val? 

– Külső ADC (FPGA-s fejlesztő kártyán nincs): 

hagyományosan egy külső bővítő kártyán lévő 

funkció

• Minden esetben megvalósítható

– Belső-integrált ADC (FPGA-n belüli „on chip” 

funkció)

• Csak bizonyos FPGA-kon, ill. CPLD-ken

– Pl. Xilinx XADC IP core (Xilinx 7-es sorozatokon)
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Hagyományos vs. integrált megoldás
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Hagyományos: ADC kártya + FPGA

pl. Digilent PMOD ADs
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• PDMOD AD1: 2 csatornás Analog Devices 

AD7476 12-Bit, 1 MSPS, Low-Power A/D 

Converter

• PDMOD AD2: 2 db Analog Devices AD7476

12-Bit, 1 MSPS, Low-Power A/D Converter

(+I2C)

• PDMOD AD5: Analog Devices AD7991

4-csatornás, 24-Bit ADC, 1MSPS



SPI ADC – Xilinx Spartan3-AN

• https://www.pantechsolutions.net/project-kits/how-to-interface-spi-adc-with-spartan-3an
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SPI interfész (lassú)

ADC MCP3202

Temperature sensor

motor



Altera MAX 10 FPGA
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2 db beágyazott SAR ADC – 12-bit, 1 MSPs

• max. 18 analóg bemeneti csatorna

• hőmérséklet mérő szenzor



MicroSemi Fusion (mixed-signal FPGA)
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Beágyazott SAR ADCs – 8/10/12-bit, max. 0.6 Msps (1%)

• max. 30 analóg bemeneti csatorna

• Analóg quad: feszültség, áram-, hőmérséklet monitor



Xilinx-”7” FPGA-k - XADC

(Artix-7, Kintex-7, Virtex-7, Zynq 7000)
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1 XADC =  2 db beágyazott SAR ADC – 12-bit, 

1 MSPs (1%)

• max. 17 analóg bemeneti csatorna

• hőmérséklet mérő szenzor



XADC HOZZÁADÁSA A BEÁGYAZOTT 
RENDSZERHEZ

Xilinx Vivado használata
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Mit is jelent az XADC?

• Xilinx Analóg-Digitális Konverter blokk

– FPGA/APSoC hőmérséklet, feszültség szintek 

mérése

– Alarm funkciók – vészjelzések beállítható 

intervallumokon

– AXI4-Lite/Stream interfész v. felhasználói 

interfész

– Könnyű konfigurálhatóság (Wizard ~ GUI)

– Több csatorna kiválasztása/használata
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XADC – mint System Monitor

Miket képes mérni? „Mindent az FPGA/APSoC állapotáról”.

• Hőmérséklet: On-chip temperature sensor

• VCCInt: The internal PL core voltage

• VCCAux: The auxiliary PL voltage

• VRefP: The XADC positive reference voltage

• VRefN:The XADC negative reference voltage

• VCCBram: The PL BRAM voltage

• VCCPInt: The PS internal core voltage

• VCCPAux: The PS auxiliary voltage

• VCCDdr: The operating voltage of the DDR RAM connected to the 
PS 
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A feladat megoldásának lépései

• A korábbi (5. fólia) ismeretkör elsajátítása

során létrehozott projekt archiválása (Save

Project as…):

– LAB03 → LAB04 (majd nyissuk is meg)

• XADC IP hozzáadása a XADC IP Wizard

segítségével a Xilinx Vivado-ban,

• XADC felparaméterezése és összekapcsolása a

beágyazott rendszerrel.
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A bővítendő tesztrendszer

PS oldal:

• ARM hard-processzor mag

• belső OnChip-RAM vezérlő

• RS232 soros interfész

• külső DDR3 memória vezérlő

• I2C vezérlő
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PL oldal:

• LAB04: XADC IP hozzáadása
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PL oldali XADC IP hozzáadása és összekötése az 

alaprendszerrel I.
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• Ezután már az új IP mag hozzáadható a Vivado-ban (két lehetőség):
– a.) Block Diagram View -> Add IP 

– b.) IP katalógus megnyitása –> IP kiválasztása –> Dupla kattintással –> Add IP to Block Design

• Adjunk a processzor rendszerhez egy  PL oldali  XADC blokkot

2
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PL oldali XADC periféria hozzáadása és összekötése az 

alaprendszerrel II.
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• Ezek után az XADC IP modulhoz a Vivado-ban 

következőket szükséges beállítani (lehet 

manuális / automatikus is!):

– a.) interfész kapcsolatot az IP modul és 

buszrendszer (AXI Lite) között,

– b.) IP modul címtartományhoz rendelését (Base-

High Addresses),



Block Diagram
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Kattintsunk duplán az XADC-re, majd paraméterezzük fel.



XADC_Wizard (GUI): paraméterek
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XADC bekötése (autorouter)
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1
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Blokk diagram: XADC manuális bekötése
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• Block Design -> „Address Editor” nézet kiválasztása

• „Map”-eletlen („unmapped”) IP perifériák memória-
címtartományhoz rendelése:

– a.) automatikusan - címgenerálással vs. b.) manuálisan
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XADC - Memória címtartományok beállítása

1

2

*Címtartományoknak 2^n méretűeknek kell lennie 

és nem lapolódhatnak át! 



Block Design – Layout szintézis
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• Ezek után egy-egy a Block Design-t frissíteni 

kell:

– Regenerate Layout

– Validate Design (DRC)

– Flow Navigator -> Generate Bitstream

(külső portokhoz FPGA lábakat most nem fogunk rendelni, 

nem kell az .XDC-t módosítani !)



Reports (implementáció után)

• Kérdés – Mennyi erőforrást foglalunk el PL oldalon?

– Reports -> Place Design -> Utilization Report (vagy Project Summary)
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1. Slice Logic
+----------------------------+------+-------+-----------+-------+
|          Site Type | Used | Fixed | Available | Util% |
+----------------------------+------+-------+-----------+-------+
| Slice LUTs |  835 |     0 |     17600 |  4.74 |
|   LUT as Logic |  771 |     0 |     17600 |  4.38 |
|   LUT as Memory |   64 |     0 |      6000 |  1.07 |
|     LUT as Distributed RAM |    0 |     0 |           |       |
|     LUT as Shift Register |   64 |     0 |           |       |
| Slice Registers | 1063 |     0 |     35200 |  3.02 |
|   Register as Flip Flop | 1063 |     0 |     35200 |  3.02 |
|   Register as Latch |    0 |     0 |     35200 |  0.00 |
| F7 Muxes |    0 |     0 |      8800 |  0.00 |
| F8 Muxes |    0 |     0 |      4400 |  0.00 |
+----------------------------+------+-------+-----------+-------+
…
7. Specific Feature
+-------------+------+-------+-----------+--------+
|  Site Type | Used | Fixed | Available |  Util% |
+-------------+------+-------+-----------+--------+
| XADC        |    1 |     0 |         1 | 100.00 |
+-------------+------+-------+-----------+--------+



SZOFTVER TESZT ALKALMAZÁS 
ÖSSZEÁLLÍTÁSA (XADC)

Xilinx Vivado SDK
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SDK – alkalmazás-fejlesztés általános lépései

1. Vivado projekt létrehozása, majd Export → SDK,

2. Új, vagy C/C++ template-ből generálható alkalmazás 

létrehozása ( XADC alkalmazás ):

a) BSP (Board Support Package) generálása és fordítása,

b) Linker Script generálása (memória szekciók megadása, .ld),

c) SW alkalmazáskód megírása/generálása, és fordítása.

3. Soros terminál beállítása (USB-soros port beállítása),

4. JTAG-USB programozó csatlakoztatása és beállítása,

5. FPGA konfigurálása!! ( .bit, van PL oldal )

6. ‚debug’ – hardveres hibakeresés beállítása

7. Debug (breakpoint-ok beszúrása, léptetés, stb.)
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Export HW -> Vivado SDK

• File -> Export -> Export hardware 

• File -> Launch SDK, OK.

– Vivado SDK indítása a keretrendszerből (ezt kívülről 

indítva is meg lehetne tenni)

28
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Vivado SDK GUI
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.hdf = Hardware description file = hardver konfigurációs csomag file. 
(Valójában egy zip, amely két leíró xml-t tartalmaz!) Ebből olvassa ki az SDK a beállításokat.

!
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File → New  → Application Project (sw alk. neve legyen pl. XADC_TestApp)

SDK szoftver projekt létrehozása I./a



SDK - BSP létrehozása I./b
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SDK – MSS ellenőrzése I./c
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• SDK: Válasszuk ki a system.mss fület

• Vizsgáljuk meg az „Overview”, ill. „Source” nézeteket!



SDK – BSP XADC driver hozzáadása I./d
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• Project Explorer → Jobb kaNntás a   XADC_TestApp_bsp → 
Board Support Package Settings

3

1

2



SDK - C forráskód létrehozása II./a
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File → New  → Source File (neve legyen lab05_xadc.c)

forrás kód: BER_lab_xadc.zip (másoljuk bele a tartalmát)



C forráskód I.
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xil_printf("-- PL XADC_WIZARD demonstration on ZyBo -- \n\r");
xil_printf("XADC configuration started...\n\r");

//XADC initilization

ConfigPtr = XAdcPs_LookupConfig(XPAR_AXI_XADC_0_DEVICE_ID);
if (ConfigPtr == NULL) {

return XST_FAILURE;
}

Status_ADC = XAdcPs_CfgInitialize(XADCInstPtr,ConfigPtr,ConfigPtr->BaseAddress);
if(XST_SUCCESS != Status_ADC){

print("ADC INIT FAILED\n\r");
return XST_FAILURE;

}

//self test
Status_ADC = XAdcPs_SelfTest(XADCInstPtr);

if (Status_ADC != XST_SUCCESS) {
return XST_FAILURE;

}

//stop sequencer
XAdcPs_SetSequencerMode(XADCInstPtr,XADCPS_SEQ_MODE_SINGCHAN);

//disable alarms
XAdcPs_SetAlarmEnables(XADCInstPtr, 0x0);

//configure sequencer to just sample internal on chip parameters
XAdcPs_SetSeqInputMode(XADCInstPtr, XADCPS_SEQ_MODE_SAFE);

//configure the channel enables we want to monitor
XAdcPs_SetSeqChEnables(XADCInstPtr,XADCPS_CH_TEMP|XADCPS_CH_VCCINT|XADCPS_CH_VCCAUX|XADCPS_CH_VBRA

M|XADCPS_CH_VCCPINT|
XADCPS_CH_VCCPAUX|XADCPS_CH_VCCPDRO);



C forráskód II.
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while(1){
xil_printf("\n\r Next iteration - read out XADC registers ...\n\r");

TempRawData = XAdcPs_GetAdcData(XADCInstPtr, XADCPS_CH_TEMP);
TempData = XAdcPs_RawToTemperature(TempRawData);
printf("Raw Temp %lu -> Real Temp %f [C°]\n\r", TempRawData, TempData);

VccIntRawData = XAdcPs_GetAdcData(XADCInstPtr, XADCPS_CH_VCCINT);
VccIntData = XAdcPs_RawToVoltage(VccIntRawData);
printf("Raw VccInt %lu -> Real VccInt %f [V]\n\r", VccIntRawData, VccIntData);

VccAuxRawData = XAdcPs_GetAdcData(XADCInstPtr, XADCPS_CH_VCCAUX);
VccAuxData = XAdcPs_RawToVoltage(VccAuxRawData);
printf("Raw VccAux %lu -> Real VccAux %f [V]\n\r", VccAuxRawData, VccAuxData);

VBramRawData = XAdcPs_GetAdcData(XADCInstPtr, XADCPS_CH_VBRAM);
VBramData = XAdcPs_RawToVoltage(VBramRawData);
printf("Raw VccBram %lu -> Real VccBram %f [V]\n\r", VBramRawData, VBramData);

VccPIntRawData = XAdcPs_GetAdcData(XADCInstPtr, XADCPS_CH_VCCPINT);
VccPIntData = XAdcPs_RawToVoltage(VccPIntRawData);
printf("Raw VccPInt %lu -> Real VccPInt %f [V]\n\r", VccPIntRawData, VccPIntData);

VccPAuxRawData = XAdcPs_GetAdcData(XADCInstPtr, XADCPS_CH_VCCPAUX);
VccPAuxData = XAdcPs_RawToVoltage(VccPAuxRawData);
printf("Raw VccPAux %lu -> Real VccPAux %f [V]\n\r", VccPAuxRawData, VccPAuxData);

VDDRRawData = XAdcPs_GetAdcData(XADCInstPtr, XADCPS_CH_VCCPDRO);
VDDRData = XAdcPs_RawToVoltage(VDDRRawData);
printf("Raw VccDDR %lu -> Real VccDDR %f [V]\n\r", VDDRRawData, VDDRData);



Eredmény – kiíratás (console)
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Kérdés:

• Mekkora a letöltendő .elf file mérete?

– Megoldás:

• Miért ilyen nagy a mérete?

– Megoldás: Printf() !? (formátumvezérelt kiíratás) 
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'Invoking: ARM Print Size'

arm-xilinx-eabi-size XADC_TestApp.elf |tee "XADC_TestApp.elf.size"

text data bss dec hex filename

68004 2328 22668 93000 16b48 XADC_TestApp.elf

'Finished building: XADC_TestApp.elf.size'


