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2. Beágyazott Rendszer fejlesztő szoftverkörnyezet 
(Xilinx Vivado Embedded Development) áttekintése

3. Beágyazott alap tesztrendszer (BSB - Base System 
Builder and Board Bring-Up) összeállítása

4. Perifériák hozzáadása (IP adatbázisból) az összeállított 
beágyazott alaprendszerhez. Saját periféria 
hozzáadása az összeállított beágyazott 
alaprendszerhez

5. Szoftver alkalmazások fejlesztése, tesztelése, 
hibakeresése (debug) Xilinx Vivado SDK (Software 
Development Kit) használatával 
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Mire figyeljetek? (jótanácsok)

• Figyeljünk arra, hogy a létrehozandó Vivado projekt elérési
útja NE tartalmazzon ékezetet, illetve ún. „white-space”
karaktereket!

• Megfelelő jogosultságunk legyen azon a meghajtón amin
dolgoztok:
– Hálózati meghajtóra lehetőség szerint NE dolgozzunk!

• A projekt neve, és a források nevei NE kezdődjenek
számmal, de tartalmazhatnak számot! (VHDL)

• Használjuk következetesen a kis-nagy betűket egy forrás
fájlban, és a projekten belül!

• Lehetőség szerint a projekt könyvtárának neve, projekt
neve és a forrás(ok) neve legyen eltérő, és utaljon azok
funkciójára, a hibaüzenetekben szereplő könnyebb
azonosítás végett!
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HW platform felismertetése

• Ahhoz, hogy a ZyBo HW platform, kiválasztható 
legyen a Vivado fejlesztő környezetben, a 
következő lépéseket kell megtenni (csak első 
alkalommal):

• 1.) A kártya gyártójának megfelelő támogató 
csomagot letölteni: 

Digilent ZYBO
– Vivado-hoz a támogató csomag(**): 
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ZYBO platform Xilinx Vivado alatt

• ** A gyártó oldaláról is letölthető:

– https://github.com/Digilent/vivado-boards/archive/master.zip 

• A csomagban lévő 
\vivado-zybo-master\new\board_files\zybo alkönyvtár 
átmásolása a Xilinx alkönyvtárba a következő helyre:

– ÁTMÁSOLNI → 
C:\Xilinx\Vivado\2015.x\data\boards\board_files

alkönyvtárba.
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BEÁGYAZOTT RENDSZER 
ÖSSZEÁLLÍTÁSA

Xilinx Vivado Design Suite használata
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Feladat

• Egy új projekt létrehozása a Xilinx Vivado-ban

– a BSB = Base System Builder - beágyazott alap

rendszer összeállítása (Block Designer),

– Egyszerű ARM / AXI alapú beágyazott alap
tesztrendszer (BSB) létrehozása,

– AXI-Lite ”busz” interfész alapú Xilinx IP-k
(Intellectual Property = gyártó szellemi
termékeinek) hozzáadása.
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A feladat megoldásának lépései

• Új projekt létrehozása a Xilinx Vivado beágyazott
rendszer tervezőjének segítségével,

• A létrehozott projekt áttekintése,

• (Implementációs és Bitstream generálása,
amennyiben PL oldal is konfigurálva van!)

• ARM-en futó Hello world! és Memória-teszt
alkalmazás készítése a Xilinx Vivado Software
Developement Kit (SDK) segítségével,

• Az elkészített beágyazott rendszer és szoftver
alkalmazás teszt verifikálása Digilent ZyBo kártyán
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A megvalósítandó tesztrendszer

PS oldal:
• ARM hard-processzor mag (Core0)
• belső OnChip-RAM
• UART1 (soros) interfész

• DDR3 memória vezérlő (külső)
10

PL (FPGA) oldal most nem lesz 
konfigurálva:  pl.

• GPIOk, LED_IP,

• AXI interconnection, stb.
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Xilinx Vivado indítása
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Új projekt létrehozása I.
Több lehetőség is van:
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Új projekt készítése II.
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Új projekt készítése III.
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Fejlesztő platform kiválasztása
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** Csak azután választható ki a Zybo, miután telepítettük a támogató csomagját (lásd 5-6. dia)
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Projekt összegzés - ellenőrzés
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Projekt beállítások – VHDL

• Project Manager -> Settings -> General -> 
VHDL kiválasztása, majd OK.
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Beágyazott rendszer – IP integrátor

• IP Integrátorral – új Block Design létrehozása
– 1. Create Block Design, vagy
– 2. Flow menü -> Create Block Design, 
– 3. Legyen a neve „system” (3.). Végül OK.
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Beágyazott rendszer – Add IP

• Diagram kiválasztása (system.bd)

• Majd Add IP

– „ZYNQ7 Processing System” kiválasztása (= PS) 
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CTRL+Q: IP details



IP katalógus: (adatbázis)
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• IP integráció támogatása

• Ingyenes = „included” vs. 
fizetős = „purchaze” 
(licenszelhető
– próbaidő 90 nap)

• gyors IP paraméterezés

• Vivado IP GUI: 

• kompatibilitás

• adatlapok elérése

• changelog, webpage

• Vivado „design flow”: Szintézis és
Implementáció támogatása

• .Tcl támogatás

Nyissuk meg az IP katalógust. 
• Project Manager -> IP Catalog



Milyen IP perifériák vannak?

• Bus and bridge controllers

– AXI to AXI connector

– Local Memory Bus (LMB)

– AXI Chip to Chip

– AHB-Lite to AXI

– AXI4-Lite to APB

– AXI4 to AHB-Lite…

• Debug cores

– Integrated Logic Analyzer

• DMA and Timers

– Watchdog, fixed interval

• Inter-processor communication

– Mailbox, Mutex

– ….
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• External peripheral controller 
Memory and memory controller

• High-speed and low-speed 
communication peripherals

– AXI 10/100 Ethernet MAC 
controller

– Hard-core tri-mode Ethernet 
MAC

– AXI IIC

– AXI SPI

– AXI UART…

• Other cores 
– System monitor

– Xilinx Analog-to-Digital Converter 
(XADC)

– Clock generator, System reset 
module

– interrupt controller

– Traffic Generator, Performance 
monitor

– ….



IP repository (könyvtár szerkezet)

• IP Core könyvtára (két lehetőség: a projekt könyvtárában vagy a 
központi könyvtárban = Repository - CVS/GIT )

– {component}.xml alapú leíró

– /MyProcessorIPLib directory
(user defined)

• Repo alkönyvtárak listázása:

Project Manager →
Settings →
IP Defaults / Repository tab

– %XILINX_INSTALL%\Vivado\2018.X\data\ip

22

Pl: 

Pl: 



Diagram – Run Block Automation
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Zynq Blokk Design (DDR, IO portok)
1

2

• Import XPS settings: 

Lehetőség van a 
beállítások importálására 
(gyári default preset .xml
file-tól eltérően)!



Zynq – PS-PL configuration

• General [+] -> 

– UART1 Baud rate: 115.200 ?

– Enable Clock Resets : törölni a FCLK_RESET0_N –t.

• AXI Non Secure Enablement [+] ->

– GP Master AXI interface: törölni a M AXI GP0 bridge-t . 
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Zynq PS – Peripheral IO pins

• Állítsuk be (√) az UART1-et a soros 
log-olás miatt. 

• A többi alapértelmezett blokkot 
egyelőre NE engedélyezzük, azaz 
vegyük ki a pipát előlük:

– ENET 0

– USB 0

– SD 0

– GPIO - GPIO MIO

– Memory Interfaces
- Quad SPI Flash

– Application Processor 
Unit - Timer 0 (TTC0).
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Conflict View: ha periféria MIO ütközés van, akkor hibát jelez.
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Zynq – Clock configuration

• PL Fabric Clocks (FPGA) ->
– FCLK_CLK0 törlése

• Végül: klikk OK.

• Regenerate Layout

• Validate Design (DRC)

27
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Generate top-level HDL

• Design Sources -> Create HDL wrapper ->

– Let Vivado manager wrapper and auto-update
Megj: top-level wrapper nélkül nem futna majd az implementáció

System_wrapper.vhd keletkezik:

28

2
1



Export HW -> Vivado SDK

• RTL Analysis -> Open Elaborated Design

• File -> Export -> Export hardware 

• File -> Launch SDK, Útvonalak beállítása, OK.

– Vivado SDK indítása a keretrendszerből (ezt kívülről 
indítva is meg lehetne tenni)

29



SZOFTVER TESZT ALKALMAZÁS 
ÖSSZEÁLLÍTÁSA

Xilinx Vivado SDK használata
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SDK – alkalmazás-fejlesztés általános lépései

1. Vivado projekt létrehozása, majd Export → SDK,

2. Új üres, vagy C/C++ template-ből generálható 
alkalmazás létrehozása (legyen egy Hello World, ill. egy 
Memória-teszt alkalmazás):

a) BSP (Board Support Package) generálása és fordítása,

b) Linker Script generálása (memória szekciók megadása, .ld),

c) SW alkalmazáskód megírása/generálása, és fordítása.

3. Soros terminál beállítása (USB-soros port beállítása),

4. JTAG-USB programozó csatlakoztatása és beállítása,

5. FPGA konfigurálása ( .bit, ha van PL oldal)

6. ‚debug’ – hardveres hibakeresés beállítása

7. Debug (breakpoint-ok beszúrása, léptetés, stb.)
31



Vivado SDK

32

.hdf = Hardware description file = hardver konfigurációs csomag file. 
(Valójában egy zip, amely két leíró xml-t tartalmaz!) Ebből olvassa ki az SDK a beállításokat.



Teszt alkalmazás készítése I.
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Teszt alkalmazás készítése II.
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BSP – system.mss (grafikus nézet)
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.MSS: Microprocessor Software Specification (system.mss) 



BSP – system.mss (szöveges nézet)
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.MSS: Microprocessor Software Specification (system.mss) 

BEGIN OS # alap beágyazott OS –
„standalone”

PARAMETER OS_NAME = standalone
PARAMETER OS_VER = 6.8
PARAMETER PROC_INSTANCE = ps7_cortexa9_0

#példány név
PARAMETER STDIN = ps7_uart_1
PARAMETER STDOUT = ps7_uart_1   #soros 

portra log-ol
END
……
… # az Uart1 IP modulhoz tartozó Xilinx

driver 
BEGIN DRIVER
PARAMETER DRIVER_NAME = uartps #driver 

neve fix
PARAMETER DRIVER_VER = 3.7
PARAMETER HW_INSTANCE = ps7_uart_1 
END
…



SDK Project Explorer

• SW: memory_test0 (SW alkalmazás)
– \Binaries (futtatható .elf object fájl)
– \Includes (gyári header-ek)
– \Debug
– \Src = .h, .c, .cpp források gyűjteménye
– .ld = linker script!
– Main() a memorytest.c-ben

• BSP: memory_test0_bsp (SW BSP)
– MSS: Microprocessor software/driver leíró fájl

(system.mss)

– /includes/xparameters.h (minden
kapcsolódó #define és címtartomány itt
definiálódik)

• HW platform (Vivado-ból exportált)
(.bit, .hdf)

Teszt alkalmazás készítése III.
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SW alkalmazás: memory_test.c

• xparameters.h használata (define-ok, címek)
• init_platform();

– enable_caches();

• test_memory_range(struct memory_range_s 

*range)

• test_memory_range(&memory_ranges[i])

– n_memory_ranges = 2 (memory_config.h-ban 

definiálva)

• cleanup_platform();

– disable_caches();  //$ ARM alapból engedélyezné 
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Xil_TestMemN() függvény
status = Xil_TestMem32((u32*)range->base, 1024, 0xAAAA5555, 

XIL_TESTMEM_ALLMEMTESTS);

print("          32-bit test: "); print(status == 
XST_SUCCESS? "PASSED!":"FAILED!"); print("\n\r");

status = Xil_TestMem16((u16*)range->base, 2048, 0xAA55, 
XIL_TESTMEM_ALLMEMTESTS);

print("          16-bit test: "); print(status == 
XST_SUCCESS? "PASSED!":"FAILED!"); print("\n\r");

status = Xil_TestMem8((u8*)range->base, 4096, 
0xA5, XIL_TESTMEM_ALLMEMTESTS);

print("           8-bit test: "); print(status == 
XST_SUCCESS? "PASSED!":"FAILED!"); print("\n\r");

39

Xil_TestMemN() függvény deklarációja a következő helyen van:
<xilinx_install_dir>\SDK\2015.2\data\embeddedsw\lib\bsp\standalone_v5

_1\src\common\xil_testmem.c

s32 Xil_TestMem32(u32 *Addr, u32 Words, u32 Pattern, u8 Subtest);



Teszt alkalmazás készítése IV./a.

Linker script generálása (lscript.ld)
• Xilinx Tools menü → Generate Linker Script (Basic nézet)

• Állítsuk át a memória részeket (ddr_0-ról -> ram_0-ra)

40
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Teszt alkalmazás készítése IV./b.

Linker script generálása (lscript.ld)
• Xilinx Tools menü → Generate Linker Script (Advanced nézet)

41



Fordítás (build) fontosabb lépései:

• 1.) Build Project → BSP

• 2.) Build Project → SW alkalmazás

Megjegyzés: alapértelmezettként az automatikus 
fordítás be van kapcsolva!

(Érdemes kikapcsolni: 
Project menü → Build Automatically – nincs pipa) 

42

Teszt alkalmazás készítése V.



Memória-teszt alkalmazás készítése VI.

'Building target: MemoryTest.elf'

'Invoking: ARM v7 gcc linker'

arm-none-eabi-gcc -mcpu=cortex-a9 -mfpu=vfpv3 -mfloat-abi=hard -Wl,-
build-id=none -specs=Xilinx.spec -Wl,-T -Wl,../src/lscript.ld -
L../../MemoryTest_bsp/ps7_cortexa9_0/lib -o "MemoryTest.elf"  
./src/memory_config_g.o ./src/memorytest.o ./src/platform.o -Wl,--
start-group,-lxil,-lgcc,-lc,--end-group

'Finished building target: MemoryTest.elf'

' '

'Invoking: ARM v7 Print Size'

arm-none-eabi-size MemoryTest.elf |tee "MemoryTest.elf.size"

text data bss dec hex filename

28368 1184 8248 37800 93a8 MemoryTest.elf

'Finished building: MemoryTest.elf.size'

Decimal: 37800 byte ~38 KByte . Azaz a program el tud férni mind a belső on-chip 
RAM 0/1, mind pedig a külső DDR RAM memóriában. PL/FPGA-oldalon viszont ekkora 
BRAM memóriát kellene lefoglalni. Ezért generálódott a futtatható .elf fájl is sikeresen.

SW alkalmazás fordításának eredménye:
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Beágyazott rendszer és szoftver teszt-verifikációja I.
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• A USB-soros kábel (táp+programozó) csatlakoztatása
– JP7 jumper = USB power!
– JP5 jumper = JTAG mód!

• Az ZyBo kártya bekapcsolása

ZyBo – Xilinx USB programming
cable

VCC3V3 – piros VREF (6)
GND – fekete GND (5)

TCK-JTAG – sárga TCK (4)
TDO-FX2 – lila – TDO (3)
TDI-JTAG – fehér TDI (2)
TMS-JTAG – zöld TMS (1)

1

6

!
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Amennyiben Vivado-ban konfigurálva lett a PL oldal is:
• FPGA felprogramozása:  Xilinx Tools → Program FPGA
• MemoryTest.elf fájl kiválasztása → Program

– A MemoryTest.elf és a system.bit, (system.bmm) fájlok 
összekombinálása (merge) →  egyetlen download.bit fájlba.

– Végül download.bit fájl letöltése az PL/FPGA-ra*

Beágyazott rendszer és szoftver teszt-verifikációja I.

1

2



HW-es hibakeresés konfigurálása
• Jelöljük ki a Project Explorer-ben az alkalmazást (MemoryTest)

• Run → Debug Configurations… (vagy jobb gomb Debug As…)
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HW-es hibakeresés konfigurálása
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• Debug Configurations -> Target Setup
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2
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• SDK - Window menü -> Show view -> Terminal.

• Terminal: BaudRate / Adatbitek beállításai a 
PS UART vagy / AXI_UART IP modulban adottak 
szerint!

• Port: COM[XY] – beállítását a „Vezérlő pult → 

Hardver eszközök” beállításai szerint adjuk meg

1

2

3

Debug soros port beállítása (SDK Terminal)



Debug – Hibakeresés
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Beágyazott rendszer és szoftver teszt-verifikációja IV.

• Az SDK Terminal ablakban látható a memória-teszt
alkalmazás futásának eredménye

• Ha az összeállított rendszer összeállítása helyes volt,
akkor a tesztnek sikeresen le kell futnia (PASSED!),
minden adatbit szélességre 



Debug folyamat terminálása

• A HW-es hibakeresés végén nagyon fontos terminálni
és eltávolítani a futtatott debug konfigurációt!
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Példa 1.) Hello World
• MemoryTest-hez hasonlóan hozzon létre egy template-

ből generálható HelloWorld alkalmazást (lásd köv oldal)

• (hozzá tartozó saját BSP-vel).
– Mekkora a Hello_world.elf file mérete? (~28.7 - 37 Kbyte).

• A main függvényben a következő a módosítás (printf):

52

int main()

{

init_platform();

unsigned int i = 0;

do{

//printf("Hello World (%d)\n\r",i);  //printf()  = nagy

mem. foglalása van

xil_printf("Hello World (%d)\n\r",i);  //xil_print() 

vagy print() kis mem. foglalás. FPGA-ra optimalizált.

i++;

}while(1);

return 0;

}

• Kérdés: Mekkora lett a printf()-el fordított .elf file mérete? 



Példa 2.) Kód analízis

• Vizsgálja meg a MemoryTest SW mintaalkalmazás 
forráskódjait:

• \src\
– memory_config.h (struktúra definíció)

• memory_range_s

– memory_config_g.c (struktúra ddr vs.   ram1)

– memorytest.c (main függvény)

– platform_config.h

– platform.c

• \<*_bsp>\ps7_cortexa9_x\include\
– xparameters.h (#defines .hdf/.xml szerint)
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Példa 3.)

• Módosítsa úgy a memória teszt alkalmazást
úgy, hogy az a különböző 8-/16-/32-bites
adatszélességeknél a jelenleginél nagyobb
külső ddr0 memória tartományt (1024 szó
helyett … akár 8-32…512 MByte!) teszteli le!

• Segítség: 511 MB = 0x1FF0_0000 = range->size

– TestMem32(): (range->size)/64 (?), esetleg

– TestMem16(): (range->size)/32,

– TestMem8(): (range->size)/16.
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Példa 3.) folytatás
• „memset()” függvénnyel nullázzuk ki a tesztelendő 

régiókat és adjuk a memorytest.c alkalmazás kódhoz:
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Name https://linux.die.net/man/3/memset
memset - fill memory with a constant byte 
Synopsis
#include <string.h> void *memset(void *s, int c, size_t n); 

Description
The memset() function fills the first n bytes of the memory area pointed to by s with the constant byte c. 

#include "string.h"

...

memset((u32*)range->base, 0x0, 1024);

status = Xil_TestMem32((u32*)range->base, 1024, 0xAAAA5555, XIL_TESTMEM_INCREMENT);

print("          32-bit test: "); print(status == XST_SUCCESS? "PASSED!":"FAILED!"); 

print("\n\r");

memset((u16*)range->base, 0x0, 2048);

status = Xil_TestMem16((u16*)range->base, 2048, 0xAA55, XIL_TESTMEM_INCREMENT);

print("          16-bit test: "); print(status == XST_SUCCESS? "PASSED!":"FAILED!"); 

print("\n\r");

memset((u8*)range->base, 0x0, 4096);

status = Xil_TestMem8((u8*)range->base, 4096, 0xA5, XIL_TESTMEM_INCREMENT);

print("           8-bit test: "); print(status == XST_SUCCESS? "PASSED!":"FAILED!"); 

print("\n\r");



Példa 4.)

• Állítsuk be a HW-es hibakaresés során a 
Memory ablakot: 

– Window → Show View → Memory

• [+] Adjuk meg: 0x100000   (vagy 0xffff0000)
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A HW-es hibakaresés előtt érdemes kikapcsolni az FPGA-s kártyát (random memória 
bejegyzések miatt) !



Összefoglalás

• A Block Designer segítségével könnyen és egyszerűen lehet
létrehozni ARM/MicroBlaze processzor alapú beágyazott
rendszereket a Xilinx Vivado-ban

• A folyamat részeként számos implementációs fájl is létrejön
köztük a rendszert leíró .HDF (Hardver Definition File) fájl.

• A Vivado IP Integrator különböző nézetei segítségével
beállíthatjuk az összeállított beágyazott rendszer
komponenseit, és különböző paramétereit.

• A rendszer összeállítása után generálhatjuk a konfigurációs
állományt (bitstream, amennyiben van PL tartalom!).

• A létrehozott BSP-re épülően a Software Development Kit
(SDK) segítségével készíthetjük el a szoftver alkalmazást,
melynél számos template (sablon) áll a rendelkezésünkre.

• A HW/FW és a SW helyes működése verifikálható a
bitstream .BIT+futtatható .ELF FPGA-ra történő letöltésével.
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