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Tárgyalt ismeretkörök

1. Bevezetés – Beágyazott rendszerek, FPGA-k, Digilent
ZYBO fejlesztő kártyák és eszközök

2. Beágyazott Rendszer fejlesztő szoftverkörnyezet 
(Xilinx Vivado Embedded Development) áttekintése

3. Beágyazott alap tesztrendszer (BSB - Base System 
Builder and Board Bring-Up) összeállítása

4. Perifériák hozzáadása (IP adatbázisból) az 
összeállított beágyazott alaprendszerhez. Saját 
periféria hozzáadása az összeállított beágyazott 
alaprendszerhez

5. Szoftver alkalmazások fejlesztése, tesztelése, 
hibakeresése (debug) Xilinx Vivado SDK (Software 
Development Kit) használatával 
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IP HOZZÁADÁSA A BEÁGYAZOTT 
RENDSZERHEZ

Xilinx Vivado használata
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Feladat

• Vivado – Block Design:

– Katalógusban lévő IP-k (Intellectual Property)
hozzáadása az elkészült hardver rendszerhez,

– Az .XDC fájl módosítása: az IP magok külső port-
okhoz rendelése (lábak),

• Vivado SDK

– fordító beállításainak testre szabása,

– Teszt-alkalmazás generálása, és megírása a
beépített SW template (sablon) alapján.
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A feladat megoldásának lépései

• Az előző (03. fólia) ismeretkör elsajátítása során
létrehozott projekt archiválása (LAB01 → LAB02

néven), majd pedig a \LAB02 megnyitása Vivado-
ban,

• Az IP katalógusból kiválasztott GPIO perifériák
integrálása és összekötése az alaprendszerrel,

• Külső GPIO portok létrehozása (.XDC),

• Egy Periféria teszt-alkalmazás (TestApp) készítése
az SDK-környezetben,

• A FW+SW tervek teszt verifikálása a Digilent ZyBo
kártyán.
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BEÁGYAZOTT RENDSZER ÉS SZOFTVER 
ALKALMAZÁS ÖSSZEÁLLÍTÁSA

A. NYOMÓGOMBOK, DIP KAPCSOLÓK
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A bővítendő tesztrendszer

PS oldal:

• ARM hard-processzor mag (Core0)

• belső OnChip-RAM vezérlő

• UART1 - RS232 soros interfész

• külső DDR3 memória vezérlő

• (I2C vezérlő)
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A

AXI4-
Lite

I2C PMOD_TMP2

B

PL oldal:

• (A) LAB02_A: GPIO bemenetek

– PBSs: Push Button (nyomógomb kezelő)

– DIPs: Switches (kapcsoló kezelő)

• (B) LAB02_B: GPIO kimenet
– LEDs: LED kijelző

LED

Push-Buttons

DIP Switches

GPIO



Korábbi projekt archiválása és megnyitása
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• Hozzunk létre egy új mappát, legyen a neve \LAB02_A

– File -> Project -> Save As…   (LAB02_A)    vagy
– Másoljuk át az előző ismeretkör elsajátításakor létrehozott projektet (azaz 

a \LAB01 mappa tartalmát)

• Indítsuk el a Vivado szoftvert: 

– Start → Programok → 
Xilinx Design Tools → Vivado 2018.3 → Vivado 2018.3 

• File → Open Project → 
<projectdir>/LAB02_A/<system>.xpr → 
Open



Zynq – beállítások módosítása

Design Sources -> design_1.bd blokk design megnyitása

Processing_system7_0  megnyitása

• PS-PL configuration: 
– General -> Enable Clock Resets: 

FCLK_RESET0_N engedélyezése

– AXI Non Secure Enablement: GP Master AXI interfészben 
a M_AXI_GP0 port (híd) engedélyezése! 

• Clock configuration:
– PL Fabric Clocks: FCLK_CLK0 (100 MHz IO_PLL) engedélyezése
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GP0 GP1



Zynq blokk diagram

• Vizsgálja meg, hogy az engedélyezett

– GP0 AXI Master port,

– FCLK_CLK0 PL órajel port,

– FCLK_RESET0_N reset port megjelentek-e ?!
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PL oldali AXI GPIO perifériák hozzáadása és összekötése az 
alaprendszerrel I.
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• Új IP mag hozzáadására több lehetőség kínálkozik a Vivado-ban:
– a.) Block Diagram View -> Add IP             (vagy CTRL+I) 
– b.) IP Catalog megnyitása -> IP kiválasztása -> Dupla kattintással – Add IP to Block Design

• Adjunk a processzor rendszerhez két  PL oldali  AXI_GPIO perifériát

2

1

3

2x
1x DIP
1x PB

4
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PL oldali AXI GPIO perifériák hozzáadása és összekötése az 
alaprendszerhez II.
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• Ezek után egy-egy IP modulhoz (pl. AXI_GPIO) a 
Vivado-ban következőket szükséges beállítani 
(lehet manuális / automatikus is!):
– a.) az interfész kapcsolatot az IP modul és 

buszrendszer (AXI) között 

– b.) az IP modul címtartományhoz rendelését (Base-
High Addresses)

– c.) az IP modulok I/O portjainak külső (external) 
port-okhoz rendelése, 

– d.) Végül a külső portok fizikai FPGA lábakhoz

rendelését (.XDC szerkesztése) – IO planning.



Block Diagram
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Dupla kattintással állítsuk be egyrészt a AXI GPIO_0 (DIP kapcsolóknak), 
másrészt az AXI_GPIO_1-et (PB nyomógomboknak).
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AXI GPIO perifériák hozzáadása az alaprendszerhez II. –
DIP kapcsoló sor
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AXI GPIO perifériák hozzáadása az alaprendszerhez III. –
PB nyomógombok
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AXI GPIO perifériák átnevezése
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AXI GPIO-k bekötése (autorouter)
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Block design – teljes nézet
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Processing_system7_axi_periph
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Analizáljuk az AXI periféria interfész paramétereit!
• Mennyi slave, illetve master oldali interfésze van, és miért?



Rst_Processing_system7 (Reset)
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Analizáljuk az AXI reset generátor paramétereit, és jeleit!
• Mennyi magas / alacsony aktív reset jelet generál ?
• Mely blokkok kapják meg ezeket a reset jeleket?



• Block Design -> „Address Editor” nézet kiválasztása

• „Map”-eletlen IP perifériák memória-címtartományhoz
rendelése:
– a.) automatikusan - címgenerálással vs. b.) manuálisan
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AXI GPIO - Memória címtartományok beállítása

1

2

*Címtartományoknak 2^n méretűeknek kell lennie 
és nem lapolódhatnak át! 
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AXI GPIO - Külső portok hozzárendelése

A dip és pb nevű GPIO példányokat hozzá kell kapcsolni a ZyBo kártyán található
(dip) kapcsolókhoz és (pb) nyomógombokhoz tartozó FPGA lábakhoz:

1.) A GPIO példányok adat port-jait a külső fizikai FPGA lábakra (pin) is kell kötni,

2.) Ha kell, a külső portok neveit is definiáljuk (pl: _pin végződésűre), majd

3.) Az <system>.XDC fájl-ban meg kell adni az adott FPGA pin azonosítóját.
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Összeállított rendszer
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Block Design – Layout szintézis
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• Ezek után egy-egy a Block Design-t frissíteni kell:
– Regenerate Layout

– Validate Design (DRC)

– Flow Navigator -> Run Synthesis
• Majd - Open Synthesized Design , OK

• Utolsó lépésként még a két külső porthoz (dip_pin, 
illetve pb_pin) hozzá kell rendelni az FPGA IO 
lábakat is!
– Layout menü -> I/O Planning layout nézet



I/O Planning - lábkiosztás
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• Flow Navigator menü → Run Implementation

– Kiszűri az esetleges elkötéseket, hibákat,

– Figyelmeztető (warning) jellegű üzenetek 
megengedettek (implementálható a terv),

– Legtöbb lebegő (floating) vezetékkel sem kell 
foglalkozni (pl. Peripheral Reset, stb).

– Miközben a Vivado dolgozik érdemes megnézni a 
fordítási riportokat!

Ezután indítható el a Bitstream generálás.

• Flow Navigator → Generate Bitstream.
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Implementáció és bitstream generálás



Layout Editor - Floorplanning

28
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BLOKK DIAGRAM/RIPORTOK 
VIZSGÁLATA

Xilinx Vivado használata
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Blokk Diagram áttekintése
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• 1.) Kérdés (buszok, belső jelek)
– Mely IP periféria példányok kapcsolódnak a

processing_system7_0_FCLK_CLK0 nevű órajelhez?

– Mekkora ez az órajel?

– Mely IP periféria példányok kapcsolódnak az AXI Lite busz interfészhez?

• 2.) Kérdés (címek)
– Vázolja fel a rendszer teljes memória térképét a példánynevek

megadásával!

• 3.) Kérdés (erőforrás foglalás)
– Mennyi erőforrást foglalunk el PL oldalon?



Blokk Diagram áttekintése
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• 1.) Kérdés – Megoldás
– Mely IP periféria példányokhoz kapcsolódik a processing_system7

0_FCLK_CLK0 órajel
• processing_system7 (visszacsatolás)

• rst_processing_system7

• dip

• pb

• ps7_axi_periph

– processing_system7_0_FCLK_CLK0 órajel 100 MHz!
(ZynqPS -> Clock Configuration -> PL Fabric Clock)

– Mely IP periféria példányok kapcsolódnak az ps7_axi_periph AXI
interfész M/S_AXI portjaihoz:

• processing_system7

• dip

• pb



Blokk Diagram áttekintése

32

• 2.) Kérdés - Megoldás (Block Diagram → Address Editor /vagy
SDK .hdf)

Alacsony 
címtartomány

Magas 
címtartomány

PL oldali 
perifériák



Reports (implementáció után)

• 3.) Kérdés – Megoldás: Mennyi erőforrást foglalunk el PL
oldalon?
– Reports -> Report Utilization (vagy Project Summary )
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+----------------------------+------+-------+-----------+-------+
|          Site Type | Used | Fixed | Available | Util% |
+----------------------------+------+-------+-----------+-------+
| Slice LUTs |  596 |     0 |     17600 |  3.39 |
|   LUT as Logic |  534 |     0 |     17600 |  3.03 |
|   LUT as Memory |   62 |     0 |      6000 |  1.03 |
|     LUT as Distributed RAM |    0 |     0 |           |       |
|     LUT as Shift Register |   62 |     0 |           |       |
| Slice Registers |  819 |     0 |     35200 |  2.33 |
|   Register as Flip Flop |  819 |     0 |     35200 |  2.33 |
|   Register as Latch |    0 |     0 |     35200 |  0.00 |
| F7 Muxes |    0 |     0 |      8800 |  0.00 |
| F8 Muxes |    0 |     0 |      4400 |  0.00 |
+----------------------------+------+-------+-----------+-------+



SZOFTVER TESZT ALKALMAZÁS 
ÖSSZEÁLLÍTÁSA

Xilinx Vivado SDK használata
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SDK – alkalmazás-fejlesztés általános lépései

1. Vivado projekt létrehozása, majd Export → SDK,

2. Új, vagy C/C++ template-ből generálható alkalmazás 
létrehozása ( TestApp periféria-teszt alkalmazás ):

a) BSP (Board Support Package) generálása és fordítása,

b) Linker Script generálása (memória szekciók megadása, .ld),

c) SW alkalmazáskód megírása/generálása, és fordítása.

3. Soros terminál beállítása (USB-soros port beállítása),

4. JTAG-USB programozó csatlakoztatása és beállítása,

5. FPGA konfigurálása! ( .bit: PL oldal konfigurációja! )

6. ’debug’ – hardveres hibakeresés beállítása

7. Debug (breakpoint-ok beszúrása, léptetés, stb.)

35



Export HW -> Vivado SDK

• File -> Export -> Export hardware 

• File -> Launch SDK, OK.

– Vivado SDK indítása a keretrendszerből (ezt kívülről 
indítva is meg lehetne tenni)
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Vivado SDK

37

.hdf = Hardware description file = hardver konfigurációs csomag file. 
(Valójában egy zip, amely két leíró xml-t tartalmaz!) Ebből olvassa ki az SDK a beállításokat.

!



• 1.) A Launch SDK - Choose Location…
opciójával válasszuk ki a
<project_dir>/LAB02_A/ → majd
kattintsunk az OK-ra.

• 2.) Az SDK-ban: File → New → Xilinx Board
Support Package → kattintsunk a Finish-re.

– Új BSP neve standalone_bsp_0 is lehet akár,

– Hagyjunk mindent alapértéken.

38

Tesztalkalmazás (TestApp) készítése I.



• Software Platform Settings
– Operációs rendszer kiválasztása: standalone vs. freertos_10 (esetleg 3rd Party OS)
– Rendelkezésre álló könyvtári függvények (lib) kiválasztása

39

Tesztalkalmazás (TestApp) készítése II.



• Új projekt alkalmazás létrehozása 
(File –> New –> Application Project)
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Tesztalkalmazás (TestApp) készítése III.
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2
3
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1

2

4

Tesztalkalmazás (TestApp) készítése IV.

3
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• Új C forrás fájl létrehozása/hozzáadása (lab2_a.c):

42

1

2

3

Tesztalkalmazás (TestApp) készítése V.

BER_lab2_a_main_TestApp.zip



• Forráskód hozzáadása:
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Tesztalkalmazás (TestApp) készítése VI.

BER_lab2_a_main_TestApp.zip



• Fordító beállítása
– Jobb kattintás a TestApp-ra → C/C++ Build Settings

44

• Fontos: Mivel a programunkban van egy for() ciklus is, mely a
késleltetésért felel, és nem szeretnénk, hogy a fordító „kioptimalizálja”,
ezért állítsuk az optimalizálást (–O0) = None szintűre.
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Tesztalkalmazás (TestApp) készítése VII.



• Linker Script létrehozása
– Jobb kattintás a TestApp-ra → Generate Linker Script
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Tesztalkalmazás (TestApp) készítése VIII.

1

2



Tesztalkalmazás (TestApp.elf)

• 1.) Kérdés: Build-elés során mekkora lett az TestApp.elf file
mérete ? Milyen a mértékegysége?

– Megoldás: 32684 byte (ha optimization –O0)

46

'Finished building target: TestApp.elf'
' '
'Invoking: ARM v7 Print Size'
arm-none-eabi-size TestApp.elf |tee "TestApp.elf.size"

text data bss dec hex filename
23432 1184 8248 32864 8060 TestApp.elf

'Finished building: TestApp.elf.size'

Megjegyzés: érdemes kikapcsolni az automatikus buildelést is, mivel minden forráskód 
módosítás és mentés után újragenerálja az alkalmazás  .elf –et.

Lépés: Project Menü -> Build Automatically kikapcsolása



Program FPGA – bitstream letöltés

47
INFO: FPGA configured successfully with bitstream
"D:/__PE__/BER_2018_Vivado/lab02/project_1/system_wrapper_hw_platform_0/system_wrapper.bit"

1

2

• A JTAG-USB programozó (USB-soros) kábel csatlakoztatása a számítógéphez és 
a kártyához,

• Debug konfiguráció létrehozása (lásd lab01): a SDK Terminal-on az USB soros 
port beállítása (COMx), majd Csatlakozás…

• Digilent ZyBo kártya bekapcsolása, FPGA (PL) bitstream letöltése

– Xilinx Tools → Program FPGA  (.bit fájl kiválasztása)
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Beágyazott rendszer és szoftver teszt-verifikációja I.

1

2

3



• Kapcsolók (dip), és nyomógombok (push) működésének 
verifikációja (Peripheral_test template alapján készült)

49

Beágyazott rendszer és szoftver teszt-verifikációja II.

* A példában while(1) 
ciklus van használva a 
folyamatos 
lekérdezéshez!

Tapasztalat? 

LITTLE ENDIAN!



Jótanács: Debug terminálása

• Debuggolás végén: terminate

50
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Feladat 2: általános Periféria Teszt
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---Entering main---

Running ScuGicSelfTestExample() for ps7_scugic_0...
ScuGicSelfTestExample PASSED
ScuGic Interrupt Setup PASSED

Running GpioInputExample() for pb...
GpioInputExample PASSED. Read data:0x0

Running DcfgSelfTestExample() for ps7_dev_cfg_0...
DcfgSelfTestExample PASSED

Running XDmaPs_Example_W_Intr() for ps7_dma_s...
Test round 0
XDmaPs_Example_W_Intr PASSED

Running GpioInputExample() for dip...
GpioInputExample PASSED. Read data:0xC

Running ScuTimerPolledExample() for ps7_scutimer_0...
ScuTimerPolledExample PASSED

Running Interrupt Test  for ps7_scutimer_0...
ScuTimerIntrExample PASSED

Running Interrupt Test  for ps7_scuwdt_0...
ScuWdtIntrExample PASSED
---Exiting main---

• A beágyazott rendszeren futtassuk le a template-ből generálható
Peripheral Test-et. (ha benne van, kommentezzük ki az Ethernet részeket!)

• Készítsük el annak Debug konfigurációját is, illetve Debug-oljuk az
alkalmazást.



Összefoglalás (LAB2)

• Az előző (3.) laboron létrehozott ARM-AXI alap-
rendszerhez hozzáadtunk két új PL oldali AXI GPIO
perifériát a Vivado IP katalógusából.

• A perifériákat a megfelelő módon konfiguráltuk,
és hozzákapcsoltuk az FPGA külső lábaihoz (pin).

• Ezután megvizsgáltuk a Blokk Diagramm-ot és a
riport fileokat.

• Az lábkiosztásokhoz hozzárendeltük a ZyBo
kártyán lévő DIP kapcsolókat (4), ill. PB
nyomógombokat (4).

• Végül verifikáltuk az elkészült beágyazott
rendszert és a SW alkalmazás működését
(Periféria Teszt).
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BEÁGYAZOTT RENDSZER ÉS SZOFTVER 
ALKALMAZÁS ÖSSZEÁLLÍTÁSA

LAB02_B. LED vezérlő

53
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A bővítendő tesztrendszer

PS oldal:

• ARM hard-processzor mag

• belső OnChip-RAM vezérlő

• RS232 soros interfész

• külső DDR3 memória vezérlő

• I2C vezérlő

54

A

B

AXI4-
Lite

I2C PMOD_TMP2

PL oldal:

• (A) LAB02_A: GPIO bemenetek

– PBSs: Push Button (nyomógomb kezelő)

– DIPs: Switches (kapcsoló kezelő)

• (B) LAB02_B: GPIO kimenet

– LEDs: LED kijelző

LED

Push-Buttons

DIP Switches



Példa 1: LED vezérlő hozzáadása
Lépések:
• A LAB02_A ismeretkör elsajátítása során létrehozott projekt

archiválása,
– átmásolása (LAB02_B néven), majd megnyitása a Xilinx Vivado-ban.
– Alternatív megoldásként a File -> Save Project As… használható.

• LED vezérlő: a Vivado IP katalógusából kiválasztott AXI_GPIO
periféria integrálása és összekötése az alaprendszerrel (4-bites, mivel
4 LED van),
– Base Addr: 0x4123_0000 (méret: 64 K)
– IP példány neve legyen „leds_4bit”. Output irányú - 4 bites.

• Külső GPIO LED portok FPGA lábakhoz rendelése,
– Külső láb neve legyen: led_pin

• Block Design vizsgálata, DRC, majd Bitstream generálás!
SDK: (HW Export után)
• Egy Periféria teszt-alkalmazás (PeriphTest) készítése a Xilinx SDK-

környezetben (template-ből generálható),
• Debug Configuráció: a FW-SW tervek teszt verifikálása a ZyBo

kártyán.
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LED – GPIO megoldás
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Példa 2.) LED-es számláló

• Módosítsa az előző Példa 1.) szereplő Periféria
Teszt SW alkalmazását úgy, hogy a LED-eket egy 4-
bites bináris számláló értékének növelésével
egymás után villantsa fel.

• Segítség:
– Használja a beépített pl. u8 adattípust

– Mivel sys_clk = 100 MHz, késleltesse a LED-ek fel-
/le-villanását (pl. for() ciklussal), úgy hogy a
felvillanások ideje érzékelhető legyen.

– xparameters.h fileból a makrók használata, fordítási
hiba esetén (pl. re-defining)

– LED_DELAY, GPIO_BITWIDTH beállítása!
(xgpio_tapp_example.c)

57

BER_lab2b_led4bit_count.zip



Példa 3.) LED-es fényfüzér

• Módosítsa az előző Példa 2.) szereplő Periféria

Teszt SW alkalmazását úgy, hogy a LED-ek
értékét mindig egy pozícióval shifteli balra
(növekvő bináris súlyú számláló)
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Segítség:  BER_lab2b_led4bit_shift.zip



Példa 4.) „Knight Rider”-es fényfüzér

• Módosítsa az előző Példa 3.) szereplő Periféria 

Teszt SW alkalmazását úgy, hogy a LED-ek 
értékét mindig egy pozícióval shift-eli balra, 
majd amikor eléri a végértéket visszafelé, 
jobbra shift-eli (növekvő, illetve csökkenő 
bináris súlyú számláló segítségével)
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Segítség:  BER_lab2b_led4bit_knightrider.zip



Példa 5.) elemi „Calculator”

• Módosítsa a korábbi példát úgy, hogy egy 4-
alapműveletre képes számológépet kapjunk. Két 
operandus (A,B) egyenként 2-2bites: A[1:0], 
B[1:0], melyek a dip kapcsolók értékeit jelentik. 

• Nyomógombok (pb) segítségével legyenek a 
következő műveletek:

– Pb[0] = ’1’ : összeadás, Pb[1] = ’1’ : kivonás, Pb[2] = 
’1’ : szorzás, Pb[3] = ’1’ : osztás.

– Ezek eredményeit - az osztás kivételével - jelenítse 
meg a LED[3:0]-n (osztás esetén xprintf()-el) 

60Segítség: BER_lab2_calculator.zip


