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5. VIVADO – EMBEDDED SYSTEM
Adding GPIO peripherals to BSB from IP Catalog



1. Introduction – Embedded Systems

2. FPGAs, Digilent ZyBo development platform

3. Embedded System - Firmware development environment (Xilinx Vivado – „EDK” 

Embedded Development)

4. Embedded System - Software development environment (Xilinx VITIS – „SDK”)

5. Embedded Base System Build (and Board Bring-Up) 

6. Adding GPIO Peripherals (from IP database) to BSB

7. Adding Custom (=own) Peripherals to BSB

8. Development, testing and debugging of software applications – Xilinx VITIS (SDK)

9. Design and Development of Complex IP cores and applications (e.g. camera/video/ 

audio controllers)

Topics covered
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• Make sure that the path of the Vivado/VITIS project to be

created does NOT contain accented letters or "White-space"

characters!

• Have permissions on the drive you are working on:

– If possible, DO NOT work on a network drive!

• The name of the project and source files should NOT start with

a number, but they can contain a number! (due to VHDL)

• Use case-sensitive letters consistently within a source file and

a project!

• If possible, the name of the project directory, project and

source file(s) should be different and refer to their function for

easier identification of possible error messages.

Important notes & Tips
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XILINX VIVADO DESIGN SUITE
Adding IP cores to the Embedded Base System



• Vivado – Block Designer

– Add IP (Intellectual Property) cores to the

formerly elaborated block design (Embedded Base

System) from the IP Catalog,

– Parameterize IP blocks, set connections, interfaces,

address, and external ports (modify .XDC if

needed),

• VITIS - SDK

– Customize compiler settings,

– Creating a software application (from pre-defined

template)

Task
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• Create a new project based on previous laboratory (04.) by

using the Xilinx Vivado (IPI) embedded system designer,

– LAB01 project → Save as… → LAB02_A

• Select and add GPIO peripherals to the base system

• Parameterize and connect them, make external ports

• Overview of the created project,

– Implementation and Bitstream generation (.BIT) is now necessary,

because PL side will also be configured!

• Create peripheral „TestApp” software application(s) running on

ARM by using the Xilinx VITIS environment (~SDK),

• Verify the operation of the completed embedded system and

software application test on Digilent ZyBo.

Main steps to solve the task
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XILINX VIVADO DESIGN SUITE
LAB02_A. PUSH BUTTONS, DIP SWITCHES (GPIOs)



PS side:

• ARM hard-processor (Core0)

• Internal OnChip-RAM controller

• UART1 (serial) interface

• External DDR3 memory controller

• Global Timer

Test system to be implemented
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• Start Vivado

– Start menu → Programs → Xilinx Design Tools → Vivado 2020.1

• Open the previous project! (LAB01)

– File → Project → Open… / Open Recent…

– <projectdir>/LAB01/<system_name>.xpr → Open

• File → Project → Save As… → LAB02_A

– (This will save former project LAB01 as LAB02_A)

Project – Open / Save as…
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• Open Design Sources → system.bd blokk design (double click)

– Open Processing_system7_0

• PS-PL configuration: 

– > General → Enable Clock Resets: 

enable FCLK_RESET0_N

– > AXI Non Secure Enablement: GP Master AXI interface

enable M_AXI_GP0 port! 

• Clock configuration:

– PL Fabric Clocks: enable FCLK_CLK0 ( 100 MHz IO_PLL)

Modify Zynq PS settings
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• Examine, that the previosly enabled ports:

– GP0 AXI Master    interface,

– FCLK_CLK0    PL-side clock,

– FCLK_RESET0_N    reset port         are visible now?

– What do you think about their functionality?

Zynq PS – Block diagram
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• Adding new IP cores – possible ways:

a) Block Diagram View → Add IP OR

b) Open IP Catalog → Select IP → Double click – Add IP to Block Design

• Add 2 PL side AXI_GPIO peripherals to the processor system

Adding and connecting AXI GPIO 
peripherals to the PL-side
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• For each IP modul (e.g. AXI_GPIO) the

following should be set:

– a.) interface connection between the IP modul 

and bus system (AXI),

– b.) mapping IP modul to the PS address space

(Base-High Addresses),

– c.) assigning I/O ports of IP modules to external 

ports,

– d.) finally, assigning external ports to physical

FPGA pins (.XDC editing) – I/O planning.

Adding and connecting AXI GPIO 
peripherals to the PL-side (cont.)
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AXI GPIO_0 as DIP switches (DIP) and AXI_GPIO_1 as push

buttons (PB).

Adding GPIOs – Block Diagram view
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Set AXI_GPIO peripheral - Dip switches
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Set AXI_GPIO peripheral - Push buttons
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Renaming AXI GPIO peripherals
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Connecting AXI GPIOs (autorouter)

19

1

2

3
4



Block Design – Analyzis
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Analyze the parameters of AXI peripheral interface:

• How many slave-, and master interfaces does it have?

Analyzis – Processing_system7_axi_periph
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Analyzis – Rst_Processing_system7 (Reset)
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Analyze the parameters of AXI reset generator:

• How many low-/and high assertion reset signals does it have?



• Block Design → select „Address Editor” tab

• Map „unmapped” GPIO IP peripherals into the

memory address space (automatically or manually)

Set memory addresses – AXI GPIO
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* Address ranges must be limited to 2 ^ n in size and 
must not overlap!



The dip and pb GPIO instances must be connected to the physical FPGA pins of the

(dip) switches and (pb) pushbuttons on the ZyBo platform:

1. The data ports of GPIO instances must also be connected to external FPGA pins,

2. We also define the names of the external ports (e.g. ending in _pin),

3. In the <system> .XDC file the proper FPGA pin must be specified.

Making external ports – AXI GPIO
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• Update the Block Design:

– Regenerate Layout

– Validate Design (DRC)

– Flow Navigator → Run Synthesis

• Open Synthesized Design, OK

• At the final step, the FPGA I/O pins must also be 

assigned to the two external ports 

(dip_pin and pb_pin, respectively)!

– Layout menu →  I/O Planning layout view

Block Design – Layout synthesis
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Block Design – Full view
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I/O Planning – Pin assignment
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Implementation and Bitstream
generation
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• Flow Navigator menu → Run Implementation

– It can filters out possible wrong assignments / errors,

– Warning messages are allowed (the design can be 

implemented),

– Some floating wires are also allowed (e.g. Peripheral Reset, 

etc.).

– While Vivado is working you can check out the 

synthesis/implementation reports!

Finally, run the Bitstream generation:

• Flow Navigator → Generate Bitstream



• What is the physical package pin value of the push

buttons (pb)?
– R18 = pb_pin_tri_i[0]

– P16 = pb_pin_tri_i[1]

– V16 = pb_pin_tri_i[2]

– Y16 = pb_pin_tri_i[3]

• What is the physical package pin value of the dip

switches (dip):
– G15 = dip_pin_tri_i[0]

– P15 = dip_pin_tri_i[1]

– W13 = dip_pin_tri_i[2]

– T16 = dip_pin_tri_i[3]

• What are their directions?

– All „IN” as INput direction

Q & A 1.)
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Layout Edutor – Floorplanning
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XILINX VIVADO DESIGN SUITE
LAB02_A. ANALYZING BLOCK DIAGRAM AND RIPORTS



• Question 1.) (buses, internal signals)

– Which IP peripheral instance(s) are associated with the

clock named processing_system7_0_FCLK_CLK0?

– What is its frequency?

– Which IP peripheral instance(s) are connected to the AXI

Lite bus interface?

• Question 2.) (addresses)

– Outline a full memory space / map of the system by

specifying instance names!

• Question 3.) (resource utilization)

– How many resources are utilized on the PL/FPGA side?

Analyzing Block Diagram
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• Question 1.) Solution

– Which IP peripheral instance(s) are associated with the clock named

processing_system7_0_FCLK_CLK0 ?

• processing_system7 (feedback)

• rst_processing_system7

• dip

• pb

• ps7_axi_periph

– Clock processing_system7_0_FCLK_CLK0 is:

• 100 MHz! (Just check it: ZynqPS → Clock Configuration → PL Fabric Clock)

– Which IP peripheral instance(s) are

connected to the AXI Lite bus interface?

• processing_system7

• dip

• pb

Analyzing Block Diagram (cont.)
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• Question 2.) Solution
– memory space: Block Diagram → Address Editor or VITIS .XSA

Analyzing Block Diagram (cont.)
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• Question 3.) Solution
– How many resources are utilized on the PL/FPGA side?

• Reports tab → Report Utilization (vagy Project Summary )

Analyzing Block Diagram (cont.)
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+----------------------------+------+-------+-----------+-------+
|          Site Type | Used | Fixed | Available | Util% |
+----------------------------+------+-------+-----------+-------+
| Slice LUTs |  566 |     0 |     17600 |  3.22 |
|   LUT as Logic |  504 |     0 |     17600 |  2.86 |
|   LUT as Memory |   62 |     0 |      6000 |  1.03 |
|     LUT as Distributed RAM |    0 |     0 |           |       |
|     LUT as Shift Register |   62 |     0 |           |       |
| Slice Registers |  815 |     0 |     35200 |  2.32 |
|   Register as Flip Flop |  815 |     0 |     35200 |  2.32 |
|   Register as Latch |    0 |     0 |     35200 |  0.00 |
| F7 Muxes |    0 |     0 |      8800 |  0.00 |
| F8 Muxes |    0 |     0 |      4400 |  0.00 |
+----------------------------+------+-------+-----------+-------+



• File → Export → Export Hardware…

VIVADO Export HW → VITIS (~SDK)
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VIVADO Export HW → VITIS (cont.)
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Select „Include bitstream” option as output:
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Export HW → VITIS (cont.)
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Set XSA* file name and export directory path:

*Xilinx® Support Archive: new hw descriptor format since VITIS 2020.x (see the next slide)

1

2

3



USING XILINX VITIS
LAB02_A. Creating a software test application



1. Creating a Vivado project, then Export HW → VITIS,

2. Creating a new application or an application generated from

a C/C ++ template (e.g. TestApp peripheral test):

a. Importing .XSA

b. Generating and compiling an application project containing a

platform and a domain inside (~BSP: Board Support Package),

c. Generating a Linker Script (specifying memory sections, .LD),

d. Writing / generating and compiling the SW application

3. Setup a Serial terminal/Console (USB-serial port),

4. Connecting and setup a JTAG-USB programmer,

– Configuring the FPGA (.BIT if PL-side existing)

5. Creating a ‘Debug Configuration’ for hardware debugging

6. Debug (insert breakpoints, stepping, run, etc.)

VITIS – General steps of application
development
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Starting VITIS

41

• Set workspace directory properly (lab02_a):

– Recommended to use vitis_workspace as a  

subdirectory in your lab folder. Then Launch...

1

2

OR externally

From Vivado:  Tools menu → Launch VITIS IDE 



Xilinx VITIS – Create Application
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Recall the steps of the former LAB01!

1. Create a new application project

– File → New → Application Project…

2. Platform – Create a new platform from HW (XSA)

– Browse… for LAB02  system_wrapper.xsa. Open it.

– Do not select the „Generate boot components”

3. Application project details

– Type „TestApp” as project name

– Type „Zybo_test_system” as system project name

– Select ps7_cortexa9_0 as target ARM core 0 

4. Domain: leave settings as default (standalone)



Create Application (cont)
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• x

Example I.) Creating TestApp
application
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VITIS GUI – Main window
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VITIS – HW platform
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• Software Platform Settings
– Selected OS: standalone vs. freertos_10 (or 3rd Party OS)

– Supported SW libraries (lib) 

VITIS – BSP Board Support Package

47.MSS: Microprocessor Software Specification (system.mss) 



• What is the IP type and IP version of „dip” and „pb”

instances?

– axi_gpio,

– v2.0

• What is the driver name of them?

– gpio

• Calculate what size they are?

– dip: 0x4120 0000–0x4120 ffff = 64 KByte

– pb: 0x4121 0000–0x4121 ffff = 64 KByte

Q & A 1.)
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• Add/Create new source (lab2_a.c) to the application

project

Add C/C++ source(s)
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!
1
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5

Download and unpack the archive from

laboratory website:

BER_lab2_a_main_TestApp.zip



TestApp – source code

50BER_lab2_a_main_TestApp.zip



• system_wrapper as HW platform was
exported from Vivado (.xsa, .bit, etc.)

– System_wrapper.bit (FPGA configuration = bitstream)

contains:
– BSP: (OS routines, device drivers, etc.)

• MSS: Microprocessor software/driver descriptor

(system.mss)

• /includes/xparameters.h !!! (all related #define

and address ranges are defined here)

• Zybo_test_system as system_project

contains
– SW: TestApp (SW application)

• \Binaries (executable load file as .elf object file)
• \Includes (factory default headers)

• \Debug

• \Src = collection of .h, .c, .cpp sources (e.g. lab2_a.c)

• .ld = linker script!
• Main() entry point in the helloworld.c file.

VITIS – Project Explorer / Hierarchy
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• 1. Select Application project (e.g. TestApp)

• 2. Project menu → Build Project… in two steps:

– Build BSP (system_wrapper)

– Build software application (lab2_a.c)

Build project
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Build project – Result (Console)
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'Building target: TestApp.elf'

'Invoking: ARM v7 gcc linker'

arm-none-eabi-gcc -mcpu=cortex-a9 -mfpu=vfpv3 -mfloat-abi=hard -Wl,-
build-id=none -specs=Xilinx.spec -Wl,-T -Wl,../src/lscript.ld -
LF:/Vivado_2020.1/lab02_a/vitis_workspace/system_wrapper/export/syste
m_wrapper/sw/system_wrapper/domain_ps7_cortexa9_0/bsplib/lib -o 
"TestApp.elf"  ./src/lab2_a.o   -Wl,--start-group,-lxil,-lgcc,-lc,--
end-group

'Finished building target: TestApp.elf'

' '

'Invoking: ARM v7 Print Size'

arm-none-eabi-size TestApp.elf |tee "TestApp.elf.size"

text data bss dec hex filename

22840 1176 22584 46600 b608 TestApp.elf

'Finished building: TestApp.elf.size'

Decimal size: 46600 byte ~46 KByte . The entire program can be placed both 

the internal on-chip RAM 0/1 and the external DDR RAM. (On the PL / FPGA-

side, however, this amount of BRAM memory should be reserved). Therefore, 
the executable .elf file was also generated successfully.



1. Connect the USB-serial cable (power+programmer functionality). Please

check:

• JP7 jumper = USB power!

• JP5 jumper = JTAG mode!

2. Now Power ON the ZyBo platform

Embedded system and software test 
verification

54

ZyBo – Xilinx USB programming
cable

VCC3V3 – red VREF (6)
GND – black GND (5)

TCK-JTAG – yellow TCK (4)
TDO-FX2 – lilac – TDO (3)
TDI-JTAG – white TDI (2)

TMS-JTAG – green TMS (1)

1
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• Select the application (TestApp) in the Project Explorer 

Creating Debug Configuration
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• Select „Single Application Debug (GDB)” option

– New configuration

Create a new GDB configuration
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Lunching Debugger
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Set Debug-serial port (VITIS terminal)
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• Terminal: BaudRate / Data bits according

to the settings of PS UART or / AXI_UART IP 
modul!

• Port: COM[XY] – setting according to WINDOWS 

→ „Device Manager” → Ports (COM &LPT)



TestApp – Verification result
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What do you experience? 

LITTLE ENDIAN!



TestApp – Verification result
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• IMPORTANT! At the end of the HW debug, the running debug configuration

must be Terminated and Removed!

Terminate Debug process
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• Check compiler settings:

– Right click on TestApp → C/C++ Build Settings

Compiler settings
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• Xilinx menu → Generate Linker Script (lscript.ld) → RAM0

Linker Script generation (Basic)
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1. File → New → Application Project …

2. Select system_wrapper.xsa as platform

3. Add „Peripheral_test” as application

project name

• + Create a new system project (leave Peripheral

Test_system by default)

• Select ps7_cortexa9_0 ARM core-0

4. Leave domain settings as default

5. Templates: select „Peripheral Test”. FINISH.

Example II.)  Peripheral Test
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1. Build the built-in Peripheral Test application (.elf)

2. Lunch the proper Debug configuration (GDB) for hardware

debugging

3. Setup the VITIS serial terminal/Console (USB-serial port),

4. Connecting and setup a JTAG-USB programmer,

– Configuring the FPGA (.BIT if PL-side existing)

5. Debug procedure (insert breakpoints, stepping, run, etc.)

– Watching variables and examine memory monitor !

6. At the end of debug procedure do not forget to Terminate

and Remove the actual Debug configuration (GDB)!

7. That’s all :D

Example II.) Build and Debug
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• What is the size of the Peripheral_test application?

– ~82 Kbyte

• Generate the linker script to RAM1

(ps7_ram1) address space! What do you

experience?

– Linking ERROR. Why?

Example II.) Questions & Answers
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'Invoking: ARM v7 Print Size'
arm-none-eabi-size Peripheral_test.elf |tee 
"Peripheral_test.elf.size"

text   data    bss dec hexfilename
46796   1992  33440  82228

14134Peripheral_test.elf
'Finished building: Peripheral_test.elf.size'



Connected to COM18 at 115200
---Entering main---
Running ScuGicSelfTestExample() for ps7_scugic_0...

ScuGicSelfTestExample PASSED
ScuGic Interrupt Setup PASSED

Running GpioInputExample() for dip...
GpioInputExample PASSED. Read data:0xD

Running GpioInputExample() for pb...
GpioInputExample PASSED. Read data:0x4

Running DcfgSelfTestExample() for ps7_dev_cfg_0...
DcfgSelfTestExample PASSED
……
---Exiting main---

HW debugging steps – Peripheral_test
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1. Create a new Debug Configuration (GDB) for Peripheral_test

2. Lunch Debugger

3. Set-up Debug-serial port (VITIS terminal)

4. HW debug – Peripheral_test

5. Examine results – serial logs

6. Terminate and remove debug process!



• To the ARM-AXI base system created in the previous (4. –

LAB01), we added two PL-side AXI GPIO peripherals from the

Vivado IP catalog.

• Peripherals were properly configured and connected to the

external I/O pins of the FPGA.

• We examined both the Block Diagram and the report files.

• The DIP switches (4) and PB pushbuttons (4) on the ZyBo card

have been assigned to the pin assignments.

• Finally, we verified the completed embedded system

(HW+FW) and the correct operation of the SW application

(TestApp, and Peripheral Test) in VITIS unified environment.

LAB02 – Summary
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THANK YOU FOR 
YOUR KIND 
ATTENTION!
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