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6. VIVADO – EMBEDDED SYSTEM
Adding peripherals to BSB from IP Catalog #2 (PMOD, GPIO)



1. Introduction – Embedded Systems

2. FPGAs, Digilent ZyBo development platform

3. Embedded System - Firmware development environment (Xilinx Vivado – „EDK” 
Embedded Development)

4. Embedded System - Software development environment (Xilinx VITIS – „SDK”)

5. Embedded Base System Build (and Board Bring-Up) 

6. Adding Peripherals (from IP database) to BSB

7. Adding Custom (I2C IP and XADC) Peripherals to BSB

8. Development, testing and debugging of software applications – Xilinx VITIS (SDK)

9. Design and Development of Complex IP cores and applications (e.g. camera/video/ 
audio controllers)

Topics covered
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• Make sure that the path of the Vivado/VITIS project to be
created does NOT contain accented letters or "White-space"
characters!

• Have permissions on the drive you are working on:

– If possible, DO NOT work on a network / USB drive!

• The name of the project and source files should NOT start with
a number, but they can contain a number! (due to VHDL)

• Use case-sensitive letters consistently in source file and
project!

• If possible, the name of the project directory, project and
source file(s) should be different and refer to their function for
easier identification of error messages.

• The directory path should be no longer than 256 characters!

Important notes & Tips
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XILINX VIVADO DESIGN SUITE
Adding IP (I2C) cores to the Embedded Base System



• Vivado – Block Designer

– Add IP (Intellectual Property) cores to the
formerly elaborated block design (Embedded Base
System) from the IP Catalog,

– Parameterize IP blocks, set connections, interfaces,
address, and external ports (modify .XDC if
needed),

• VITIS - SDK

– Customize compiler settings,

– Creating a software application (from pre-defined
template)

Task
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• Create a new project based on previous laboratory (slide 05.)
by using the Xilinx Vivado (IPI) embedded system designer,

– LAB02_A project → Save as… → LAB05

• Select and add GPIO (LED) peripherals to the base system

• Parameterize and connect them, make external ports

• Overview of the created project,

– Implementation and Bitstream generation (.BIT) is now necessary,

because PL side will also be configured!

• Create peripheral „TestApp” software application(s) running on
ARM by using the Xilinx VITIS environment (~SDK),

• Verify the operation of the completed embedded system and
software application test on Digilent ZyBo.

Main steps to solve the task
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XILINX VIVADO DESIGN SUITE
LAB02_A. LED controller (GPIOs)



PS side:

• ARM hard-processor (Core0)

• Internal OnChip-RAM controller

• UART1 (serial) interface

• External DDR3 memory controller

Test system to be implemented
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• Start Vivado
– Start menu → Programs → Xilinx Design Tools → Vivado

2020.1

• Open the previous project! (LAB02_A)
– File → Project → Open… / Open Recent…

– <projectdir>/LAB02_A/<system_name>.xpr →

Open

• File → Project → Save As… → LAB02_B
– (This will save the former project LAB02_A as LAB02_B)

Project – Open / Save as…
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Vivado:

• LED controller: integrate and connect AXI_GPIO
peripherals selected from the Vivado IP catalog to the base
system (4 pieces of LEDs),

• GPIO IP instance should be named as "leds".

• GPIO Board interface: select "leds_4bits".

• Base Address: 0x4123_0000 (size: 64 K)

• Assign external GPIO LED port to FPGA pins (led_pin),

• Examine Block Design and Generate Bitstream

VITIS (~SDK):

• Create a Peripheral test application (PeriphTest) in the VITIS
SDK environment (based on the former app lab02.c !),

• Test verification of FW-SW plans on the ZyBo platform.

Task 1.) Adding LED controller
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Vivado – Completed design
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• Modify the Peripheral Test SW application
(lab02_a.c) in order to flash the LEDs by increasing
the value of a N=4-bit counter.

– Apply the PeripheralTest template

(see GpioOutputExample () function in details!)

• Help:
– Use the built-in data types (e.g. u8)

– Since sys_clk = ? (100 MHz), delay the LEDs up / down (by using
a for() cycle) so that the flash time can be percebtible: ~1 sec.

– Use macros from the xparameters.h file if a possible build error(s)
occurs

• Examine and set LED_DELAY, N=GpioWidth! (2^N)

– Solution: BER_lab2b_led8bit_count.zip

Task 2.) SW – LED counter(s)
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• Modify the application of the Peripheral Test SW in
the former Task 2.) so that the value of the 4 LEDs is
always shifted by one position to the left (as an
ascending binary weight counter).

• Help: BER_lab2b_led8bit_shift.zip.
0001

0010

0100

1000
Solution:

for (LedBit = 0x0; LedBit < (2^GpioWidth); LedBit++) 
XGpio_DiscreteWrite(&GpioOutput, LED_CHANNEL, 3 << 
LedBit);

Task 3.) SW – LED strings
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• Modify the application of the Peripheral Test SW in
the former Task e 3.) so that the value of the LEDs is
always shifted by one position to the left and when it
reaches the end, it moves backwards to the right
(using an increasing and then decreasing binary
weight counter). Put it into infinite loop.

• Help: BER_lab2b_led8bit_knightrider.zip
Solution:

for (LedBit = 0x0; LedBit < (2^GpioWidth); LedBit++) 
XGpio_DiscreteWrite(&GpioOutput, LED_CHANNEL, 3 << LedBit);

…

for (LedBit = (2^GpioWidth); LedBit >= 0x0; LedBit--) 
XGpio_DiscreteWrite(&GpioOutput, LED_CHANNEL, 3 << LedBit);

Task 4.) „Knight Rider” LED strings
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XILINX VIVADO DESIGN SUITE
LAB02_C. PMOD_TMP temperature measurement (AXI_I2C controller / 
PS_I2C controller).



PS side:

• ARM hard-processor (Core0)

• Internal OnChip-RAM controller

• UART1 (serial) interface

• External DDR3 memory controller

Test system to be implemented
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• Create a new project based on previous laboratory (slide 05.)
by using the Xilinx Vivado (IPI) embedded system designer,

– LAB02_A project → Save as… → LAB02_C

• Select and add AXI_I2C (or PS_I2C) peripheral controller to the
base system

• Parameterize and connect them, make external ports

• Overview of the created project,

– Implementation and Bitstream generation (.BIT) is now necessary,

because PL side will also be configured!

• Create peripheral „TestApp” software application(s) running on
ARM by using the Xilinx VITIS environment (~SDK),

• Verify the operation of the completed embedded system and
software application test on Digilent ZyBo.

Main steps to solve the task
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• Digilent PMOD TMP2 temperature sensor modul (I2C):

 https://store.digilentinc.com/pmod-tmp2-temperature-sensor/

 https://reference.digilentinc.com/reference/pmod/pmodtmp2/reference-manual

• Analog Devices ADT7420 sensor IC:
 http://www.analog.com/media/en/technical-documentation/data-
sheets/ADT7420.pdf

• Analog Devices – Digilent Wiki page:

 http://wiki.analog.com/resources/alliances/digilent

Reference design for FPGA (inc. SW drivers)

 http://wiki.analog.com/resources/fpga/xilinx/pmod/adt7420

• I2C standard:
 Dr. Fodor Attila, Dr. Vörösházi Zsolt: Beágyazott rendszerek, TÁMOP 4.1.2 (PE 
MIK, Villamosmérnöki és Információs Rendszerek Tanszék) 2011. – in hungarian -
http://tananyagfejlesztes.mik.uni-pannon.hu/

 I2C Wikipedia: https://en.wikipedia.org/wiki/I%C2%B2C

References
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• I2C based temperature sensor and 

temperature controller peripheral module
– TA= −40°C  … +150°C,

– max. scalable to 16-bit resolution,

– An average accuracy better than 0.25 °C,

• 13 = 9+4 bit mode: 1/24 = 0.0625 °C,

• 16 = 9+7 bit mode: 1/27 = 0.0078 °C,

– I2C interface, 4 selectable (jumper) with I2C address (A1-A0)

• „Daisy Chain” option (7/10 bit addressing)

– Continuous conversion in every 240ms,

– Programmable treshold (max/min - CT), external pins as threshold
(INT),

– 3.3V or 5V interface support,

– No calibration required!

Digilent PMOD_TMP2
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• Block diagram:

• PMOD_TMP2 signals / I2C addresses:

ADT 7420
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• Web: https://en.wikipedia.org/wiki/I%C2%B2C

Philips I2C  standard (1982)
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1. Data Transfer is initiated with a START bit 

(S) signaled by SDA being pulled low while 

SCL stays high (pull-down).

2. SDA sets the 1st data bit level while 

keeping SCL low (during blue bar time) .

3.The data is sampled (received) when SCL 
rises (green) for the first bit (B1).

4. This process repeats, SDA transitioning 

until SCL is low again, and the data being 

read while SCL is high (B2, Bn).

5. A STOP bit (P) is signaled when SDA is 

pulled high while SCL is high.
„Master write(0) to / read(1) from the Slave”



Adding I2C controller to the Base System I.
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• Add I2C controller – two possible ways by
– a.) adding PL-side AXI_I2C    IP core, OR

– b.) enabling PS-side (PS_I2C0/1) IIC  controller in Zynq PS7

• Add an AXI_IIC controller to the Block Diagram (IP Catalog)

2

1
3



Adding AXI IIC peripheral interface to the

Base System II. 
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Run Autorouter (AXI_IIC)
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Block Design – Analyze
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• Block Design → select „Address Editor” view

• Assign „UnMapped” IP peripherals to the ARM’s address
range:
– a.) automatic - vs. b.) manual address generation

AXI IIC – Set memory address
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1

2

Address ranges must be set to the size of 2^n 
and cannot be overlapped! 



The AXI_IIC instance must be connected to the FPGA (PL-side) pins on the ZyBo card (PMOD JE
3-4 signals):

1. The AXI_IIC ports must also be connected to the external physical FPGA pins,

2. If necessary, we also define the names of the external ports (ending in _pin), then

3. In the <system> .XDC file you will need to specify constraints (proper FPGA pins).

AXI IIC – Assign ports to external pins
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• Block Design must be updated:

– Regenerate Layout

– Validate Design (DRC)

– Flow Navigator → Run Synthesis
• Then - Open Synthesized Design , OK

• Finally, two FPGA I/O pins must also be 
assigned to the external ports (IIC_pin)!

– Layout menu → „IO Planning” layout view

Block Design – Layout synthesis
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• Note: If you immediately start the „Run
Implementation” without constraining pins, you will
receive the following error message:

• Cause: Vivado tryed to assign the I2C signals

– But assigned bad pin location and IO Standard (LVCMOS
1.8V)

IO Planning - Incorrect pin assignment
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ZyBo - PMOD connectors
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SCLSDA

https://www.xilinx.com/support/documentation/university/XUP%20Boards/XUPZYBO/documentation/ZYBO_RM_B_V6.pdf



1. One option is to use Vivado IO Planning (GUI)

SYNTHESIS → Open Synthesized Design → I/O Planning

Finally File → Save Constraints or CTRL+S. 

• Name the file:  „lab02c.xdc” 

I/O Planning - Correct pin assignment I.
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2. Another option is to edit .XDC constraints

File → Add Sources → Add or Create constraints
– Create File, then giva a name:  „lab02c.xdc”

IO Planning - Correct pin assignment II.
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Finally File → Save Constraints or CTRL+S. 

Name the file:  „lab02c.xdc” 



Implementation and Bitstream
generation
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• Flow Navigator menu → Run Implementation

– It can filter out possible wrong assignments / errors,

– Warning messages are allowed (the design can be 
implemented),

– Some floating wires are also allowed (e.g. Peripheral Reset, 
etc.).

– While Vivado is working you can check out the 
synthesis/implementation reports!

Finally, run the Bitstream generation:

• Flow Navigator → Generate Bitstream



• How many resources are occupied on PL-side?

Reports → Report Utilization (or Project Summary )

Q&A 1.) Reports

35

+----------------------------+------+-------+-----------+-------+
|          Site Type         | Used | Fixed | Available | Util% |
+----------------------------+------+-------+-----------+-------+
| Slice LUTs                 |  971 |     0 |     17600 |  5.52 |
|   LUT as Logic             |  899 |     0 |     17600 |  5.11 |
|   LUT as Memory            |   72 |     0 |      6000 |  1.20 |
|     LUT as Distributed RAM |    0 |     0 |           |       |
|     LUT as Shift Register  |   72 |     0 |           |       |
| Slice Registers            | 1196 |     0 |     35200 |  3.40 |
|   Register as Flip Flop    | 1196 |     0 |     35200 |  3.40 |
|   Register as Latch        |    0 |     0 |     35200 |  0.00 |
| F7 Muxes |    8 |     0 |      8800 |  0.09 |
| F8 Muxes |    4 |     0 |      4400 |  0.09 |
+----------------------------+------+-------+-----------+-------+



• Check where the I2C pins are located on the FPGA?

– Package Pins?

– Direction?

– I/O Standard?

– Pull type?

Q&A 2.) I/O Planning
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• File → Export → Export Hardware…

VIVADO Export HW → VITIS (~SDK)
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VIVADO Export HW → VITIS (cont.)
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Select „Include bitstream” option as output:

2

1



Export HW → VITIS (cont.)
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Set XSA* file name and export directory path:

*Xilinx® Support Archive: new hw descriptor format since VITIS 2020.x (see the next slide)

1

2

3



USING XILINX VITIS
LAB02_C. Creating a software test application



1. Creating a Vivado project, then Export HW → VITIS,

2. Creating a new application or an application generated from
a C/C ++ template (e.g. TestApp peripheral test):

a. Importing .XSA

b. Generating and compiling an application project containing a
platform and a domain inside (~BSP: Board Support Package),

c. Generating a Linker Script (specifying memory sections, .LD),

d. Writing / generating and compiling the SW application

3. Setup a Serial terminal/Console (USB-serial port),

4. Creating a ‘Debug Configuration’ for hardware debugging

5. Connecting and setup a JTAG-USB programmer,

– Configuring the FPGA (.BIT if PL-side existing)

6. Debug (insert breakpoints, stepping, run, etc.)

VITIS – General steps of application
development
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Starting VITIS
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• Set workspace directory properly (lab02_c):

– Recommended to use vitis_workspace as a  
subdirectory in your lab folder. Then Launch...

1

2

OR externally

From Vivado:  Tools menu → Launch VITIS IDE 



Xilinx VITIS – Create Application
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Recall the steps of the former LAB01/LAB02_A!

1. Create a new application project

– File → New → Application Project…

2. Platform – Create a new platform from HW (XSA)

– Browse… for LAB02_C  system_wrapper.xsa. Open it.

– Do not select the „Generate boot components”

3. Application project details

– Type „TestApp” as project name

– Type „TestApp_system” as system project name

– Select ps7_cortexa9_0 as target ARM core 0 

4. Domain: leave settings as default (standalone)



• x

Example I.) Creating TestApp
application
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VITIS GUI – Main window
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VITIS – HW platform
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• Software Platform Settings
– Selected OS: standalone

– Check the supported SW drivers (and its version): „axi_iic”

VITIS – BSP Board Support Package
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• What is the IP type and IP version of „axi_iic_0”

instance?

– axi_iic,

– v2.0

• What is the driver name and version of it?

– iic,

– v3.6

• Calculate what size they are?

– axi_iic_0: 0x4123 0000–0x4123 ffff = 64 KByte

Q & A 1.)
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1. Download and unpack the .zip archive

2. Import all sources to the application project

Import C/C++ source(s)
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!
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3

4

5

Download the archive from lab’s website:
BER_PmodTMP2_DriverFiles.zip



• system_wrapper as HW platform was
exported from Vivado (.xsa, .bit, etc.)

– System_wrapper.bit (FPGA configuration = bitstream)

contains:
– BSP: (OS routines, device drivers, etc.)

• MSS: Microprocessor software/driver descriptor

(system.mss)

• /includes/xparameters.h !!! (all related #define

and address ranges are defined here)

• TestApp_system as system_project

contains
– SW: TestApp (SW application)

• \Binaries (executable load file as .elf object file)
• \Includes (factory default headers)
• \Debug
• \Src = collection of .h, .c, .cpp sources

• .ld = linker script!
• Main() entry point in the main.c file.

VITIS – Project Explorer / Hierarchy
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• 1. Select Application project (e.g. TestApp)

• 2. Project menu → Build Project… in two steps:

a) Build BSP (system_wrapper)

b) Build software application (main.c)

Build project
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Build project – Result (Console)
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'Building target: TestApp.elf'
'Invoking: ARM v7 gcc linker'
arm-none-eabi-gcc -mcpu=cortex-a9 -mfpu=vfpv3 -mfloat-abi=hard -Wl,-
build-id=none -specs=Xilinx.spec -Wl,-T -Wl,../src/lscript.ld -
LF:/Vivado_2020.1/lab02_a/vitis_workspace/system_wrapper/export/syste
m_wrapper/sw/system_wrapper/domain_ps7_cortexa9_0/bsplib/lib -o 
"TestApp.elf"  ./src/lab2_a.o   -Wl,--start-group,-lxil,-lgcc,-lc,--
end-group
'Finished building target: TestApp.elf'
' '
'Invoking: ARM v7 Print Size'
arm-none-eabi-size TestApp.elf |tee "TestApp.elf.size"

text data bss dec hex filename
22840 1176 22584 46600 b608 TestApp.elf

'Finished building: TestApp.elf.size'

Decimal size: 46600 byte ~46 KByte . The entire program can be placed both 

the internal on-chip RAM 0/1 and the external DDR RAM. (On the PL / FPGA-

side, however, this amount of BRAM memory should be reserved). Therefore, 
the executable .elf file was also generated successfully.



1.) 

– Solution: check and correct the XPAR_AXI_IIC_BASEADDR define in the
ADT7420.h based on xparameters.h file

2.) 

– Solution: examine the ADT7420_IIC_ADDR for correct addressing (see
PMOD TMP2 datasheet and former slide 20-21 pp)

3.)

– Solution: find and check the define in ADT7240.h file 

If they has been successfully corrected uncomment lines 90-94 
(while) in the main.cpp.

Correct TestApp
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• Generate Linker Script to the interanal on-chip PS7
RAM0

– Set the Heap / Stack size to 2KB!

• Now rebuild the TestApp again.

Q: What is the size of TestApp.elf binary?

Build
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'Invoking: ARM v7 Print Size'
arm-none-eabi-size TestApp.elf |tee "TestApp.elf.size"

text   data    bss dec    hexfilename
27468   1144  10296  38908 97fcTestApp.elf

'Finished building: TestApp.elf.size'



• Be sure the proper connection for PMOD JE conn.

Connect PMOD TMP2 to ZyBo
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SCLSDA



1. Connect the USB-serial cable (power+programmer functionality). Please
check:

• JP7 jumper = USB power!

• JP5 jumper = JTAG mode!

2. Now Power ON the ZyBo platform

Embedded system and software test 
verification
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ZyBo – Xilinx USB programming
cable

VCC3V3 – red VREF (6)
GND – black GND (5)

TCK-JTAG – yellow TCK (4)
TDO-FX2 – lilac – TDO (3)
TDI-JTAG – white TDI (2)

TMS-JTAG – green TMS (1)

1
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• Select the application (TestApp) in the Project Explorer 

Creating Debug Configuration
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• Select „Single Application Debug (GDB)” option

– New configuration

Create a new GDB configuration
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Launching Debugger
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Set Debug-serial port (VITIS terminal)
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1

2

• Terminal: BaudRate / Data bits according

to the settings of PS UART or / AXI_UART IP 
modul!

• Port: COM[XY] – setting according to WINDOWS 

→ „Device Manager” → Ports (COM &LPT)



TestApp – Verification result

61ID Register = 0xCB
Revision ID = 3
Manufacture ID = 25

-----------------------------------------

raw temp data: 0 -> Converted temp data T = 0.000 C

raw temp data: 416 -> Converted temp data T = 26.000 C
raw temp data: 416 -> Converted temp data T = 26.000 C
raw temp data: 419 -> Converted temp data T = 26.187 C
raw temp data: 419 -> Converted temp data T = 26.187 C
raw temp data: 419 -> Converted temp data T = 26.187 C
…

• Check debug output on VITIS terminal. What did you experience?

• Analyze the source code! What is the difference between raw data vs.

converted temperature data?



• IMPORTANT! At the end of the HW debug, the running debug configuration
must be Terminated and Removed!

Terminate Debug process
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• To the ARM-AXI based system created in the previous (5. –
LAB02_A), here we added new PL-side AXI GPIO and AXI IIC

peripherals from the Vivado IP catalog.

• Peripherals were properly configured and connected to the
external I/O pins of the FPGA.

• We examined both the Block Diagram and the report files.

• LED displays (4) and IIC interfaces (2) on the ZyBo card have
been assigned to the pin assignments.

• Finally, we verified the completed embedded system
(HW+FW) and the correct operation of various SW
applications (TestApp, and Peripheral Test) in VITIS unified
environment.

LAB02_B and C – Summary
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