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1. Introduction – Embedded Systems

2. FPGAs, Digilent ZyBo development platform

3. Embedded System - Firmware development environment (Xilinx Vivado – „EDK” 

Embedded Development)

4. Embedded System - Software development environment (Xilinx VITIS – „SDK”)

5. Embedded Base System Build (and Board Bring-Up) 

6. Adding Peripherals (from IP database) to BSB

7. Creating and adding custom (Ultrasonic sensor – HC-SR04) Peripherals to BSB

8. Development, testing and debugging of software applications – Xilinx VITIS (SDK)

9. Design and Development of Complex IP cores and applications (e.g. camera/video/ 

audio controllers)

Topics covered
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• Make sure that the path of the Vivado/VITIS project to be

created does NOT contain accented letters or "White-space"

characters!

• Have permissions on the drive you are working on:

– If possible, DO NOT work on a network / USB drive!

• The name of the project and source files should NOT start with

a number, but they can contain a number! (due to VHDL)

• Use case-sensitive letters consistently in source file and

project!

• If possible, the name of the project directory, project and

source file(s) should be different and refer to their function for

easier identification of error messages.

• The directory path should be no longer than 256 characters!

Important notes & Tips
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ULTRASONIC SENSOR
HC SR04 sensor board



• HC-SR04: Ultrasonic Sensor tutorial

https://lastminuteengineers.com/arduino-sr04-ultrasonic-sensor-tutorial/

• Jordy Achten - HacksterIO tutorial: Minized and VITIS motor 

control with HC-SR04 (2020)

https://www.hackster.io/jordy-achten/minized-and-vitis-for-motor-control-

with-added-hc-sr04-0e82cb

• Xilinx Vivado – Creating custom Ips (UG1118)

 https://docs.amd.com/v/u/2019.2-English/ug1118-vivado-creating-packaging-

custom-ip

References
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Sensor Specifications:

HC-SR04 Ultrasonic sensor
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DC 3V3 (and 5V tolerant)Operating Voltage

15 mAOperating Current

40 KHz
Operating Frequency

(T: transmitter)

4 mMax Range

2 cmMin Range

~3 mmRanging Accuracy

15 degreeMeasuring Angle

10 µS TTL pulseTrigger Input Signal

45 x 20 x 15mmDimension



What is ultrasound?
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• Ultrasound is a high-pitched sound wave: it’s frequency 

exceeds the audible range of human hearing.

• Humans can hear sound waves that vibrate in the range of about 

20 times per sec (20 Hz, a deep rumbling noise) to 20,000 times 

a second (20 KHz, a high-pitched whistle). 

• Ultrasound has a frequency of more than 20 KHz and 

is therefore inaudible to humans.



• 1. VCC supplies power to the HC-SR04

sensor. You can connect it to the 3.3V of

PMOD connector.

• 2. Trig (Trigger) pin triggers ultrasonic

sound pulses. By setting this pin to HIGH

for 10µs, the sensor initiates an ultrasonic

burst.

• 3. Echo pin goes high when the ultrasonic

burst is transmitted and remains high

until the sensor receives an echo, after

which it goes low. By measuring the time

the Echo pin stays high, the distance can

be calculated.

• 4. GND: ground pin.

HC-SR04 pinout
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HC-SR04 Ultrasonic Sensor

• Trigger pin is set HIGH for 10µs. In
response, the sensor transmits an
ultrasonic burst of eight pulses at
40 kHz. This is a 8-pulse pattern.

• Pulse pattern travel through the air.
Meanwhile the echo pin goes HIGH
to initiate the echo-back signal.

• A. If pulses are not reflected back, the
echo signal times out and goes low after
38ms.

• B. If pulses are reflected back, this
generates a pulse on the echo pin whose
width varies from 150 µs to 25 ms
depending on the time taken to receive
the signal => calculate the distance!

• How does HC-SR04 Sensor work?



• The width of the received pulse is used to calculate the

distance from the reflected object.

Calculate the distance
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Example: suppose that
time := 500 µs. 
(The speed of sound is 340 m/s.)

To calculate the distance, we need to 
convert the speed of sound into cm/µs. 
It is 0.034 cm/μs. 

Distance = 0.034 cm/µs x 500 µs

Distance = (0.034 cm/µs x 500 µs) / 2

Distance = 8.5 cm



XILINX VIVADO DESIGN SUITE
Creating custom IP core to the Embedded Base System



• Vivado – Block Designer

– Create and add a custom Ultrasonic Sensor

(HC-SR04) IP peripheral to the block design

(Embedded Base System) not in the IP Catalog,

– Parameterize IP blocks, set connections, interfaces,

address, and external ports (if needed),

• VITIS - SDK

– Create SW driver

– Customize compiler settings,

– Creating a software application: HC_SR04_IP_mReadReg()

Task
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• Create a new project based on previous lab (LAB02_A) by

using the Xilinx Vivado (IPI) embedded system designer,

– LAB02_A project → Save as… → LAB05 !

• Create and generate custom IP Peripheral in Package IP Wizard,

• Select and add custom IP Peripheral to the base system,

• Parameterize and connect them, make external ports,

• Overview of the created project,

– Implementation and Bitstream generation (.BIT) is now necessary,

because PL side will also be configured!

• Create peripheral software application(s) running on ARM by

using the Xilinx VITIS environment (~SDK),

• Verify the operation of the completed embedded system and

software application test on Digilent ZyBo.

Main steps to solve the task
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• Start Vivado

– Start menu → Programs → Xilinx Design Tools → Vivado

2020.2

• Open the previous project! (LAB02_A)

– File → Project → Open… / Open Recent…

– <projectdir>/LAB02_A/<system_name>.xpr →

Open

• File → Project → Save As… → LAB05

– (This will save the former project LAB02_A as LAB05)

Project – Open / Save as…
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PS side:

• ARM hard-processor (Core0)

• Internal OnChip-RAM controller

• UART1 (serial) interface

• External DDR3 memory controller

Test system to be implemented
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PL side (in FPGA logic) 

• 2 GPIOs for Push Button and Dip
Switches

• LAB05: custom HC_SR04
Ultrasonic IP

ARM
Cortex-A9

AXI 
Interconnect

Block

DDR3 
Memory 

Controller

AXI 
Interconnect

Block

AXI-BRAM Controller
Memory

GPIO

UARTRS232 

DIP Switches

AXI4 AXI4

AXI4-
Lite

AXI4-
Lite

AXI4-
Lite

GPIO

HC_SR04_IP

Push-ButtonsAXI4-
Lite

BRAM

M_AXI_G
P0

M_AXI_G
P1

PS

PL

Timer 

AXI4-
Lite

I2C PMOD_TMP2

Echo/Trigger



Add IP path (similar to LAB03)
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• File → IP →  New Location... → Next

16



• Tools → Create and Package New IP… → Next

IP Wizard – LED IP peripheral (I.)
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1

2
3

4

AXI interfész Little-Endian, hagyományos formátumot 
definiál!

!



IP Wizard – LED IP peripheral (II.)
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1

2
3

4

= Edit in IP Packager…



Project Manager – Package IP template
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Hierarchy (design sources): 

• HC_SR04_IP_v1_0.vhd (top-level wrapper = „ 
interface logic” template)
– HC_SR04_IP_v1_0_S_AXI.vhd (user-logic =„R/W 

register template”)

1

2 3



Generate IP peripheral – IP Catalog
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NOTE: IP-XACT is a standard xml-based descriptor (component.xml) that contains definitions, macros,
descriptors of custom, reusable, pluggable IPs that can be integrated into an electronic circuit system - in our
case an embedded system.



• Open the „top-level”
HC_SR04_v1_0.vhd

Modify peripheral template I. - HDLs
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1

2

Finally (CTRL+S or Save)

3

Add the following lines to the file:



• Open „sub-level”   HC_SR04_v1_0_S_AXI.vhd-t (as „sub-modul”)

• Add the following lines to the file: :

Modify peripheral template II. - HDLs
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Finally (CTRL+S or Save)

1

2

3

4



• Still open „sub-level”   HC_SR04_v1_0_S_AXI.vhd-t (as „sub-

modul”)

• Add the following lines to the file:

• Add HC_SR04.vhd  VHDL source as „user_logic” file:

Modify peripheral template III. (cont.) 
- HDLs

Finally (CTRL+S or Save)
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BER_09_LAB05_HC_SR04.zip

5
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Synthesis – Package IP
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• Flow Navigator menu → Run Synthesis (*Save before!)

– Open Synthesized IP peripheral design, OK

– Warning messages are allowed (the design can be 

implemented),

– (Here you can simulate the behaviour of your IP periphery).

Project Manager → Edit Package IP:

• Open   HC_SR04_IP



Package IP – Customization Parameters
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1

2

3

If yellow circle on the page which means that there are warnings. These are not critical, just ignore it. 



Package IP – Review and Package
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Remember, where the 

„HC_SR04_IP" project was generated

1

2

3

5.) OK.

Finally Re-Package IP.   → YES 

(IP project will automatically close)

4

5



• Open project  → Choose „LAB05”
– Project Manager → Settings

– Select IP → + → Add IP path

Return to LAB05

27

1
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New IP core can be added in Vivado (two options):

a.) Block Diagram View→ Add IP

b.) Open IP Catalog -> Select IP→ Double-click→ Add IP to Block Design

Add your own HC_SR04_IP peripheral on the PL side to the BSB

Adding and connecting PL side 
HC_SR04_IP to the base system I.

28

2

1

3
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Now, for your own IP module (HC_SR04_IP) you need

to configure the following in Vivado (can be manual /

automatic!):

– a.) interface connection between IP module and bus

system (AXI),

– b.) assignment of the IP module to an address range (Base-

High Addresses),

– c.) assigning I/O ports of IP modules to external ports,

– d.) finally, assigning external ports to physical FPGA pins

(.XDC editing) - IO planning.

Adding and connecting PL side 
HC_SR04_IP to the base system II.
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Double-click on HC_SR04_0 and examine its parameters.

Block diagram
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• Block Design→ Select „Address Editor”

• Assign the unmapped IP peripheral into the memory address:

– a.) automatically – address generation vs. b.) manually (now)

HCSR04_IP – configure memory
address

31

1

2

*Address ranges must be aligned into 2^n size

and cannet be overlapped! 



HC_SR04_IP_0 must be connected to the FPGA pins on the ZyBo card:

1.) The data ports of the HC_SR04_IP instance must be connected to external physical FPGA pins,

2.) If necessary, define the names of the external ports (e.g. trigger_pin, and echo_pin),

then

3.) In the <system>.XDC file, the pin of the FPGA must be specified.

HC_SR04_IP – Assign external ports

32

1

3

4
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• Refresh the Block Design:

– Regenerate Layout

– Validate Design (DRC)

– Flow Navigator → Run Synthesis

• Then - Open Synthesized Design , OK

• Final step, assign trigger_pin, echo_pin to

FPGA IO pins!

– Layout menu→ IO planning layout view

Block Design – Layout synthesis

33



ZyBo - PMOD connectors

34

echotrigger

https://www.xilinx.com/support/documentation/university/XUP%20Boards/XUPZYBO/documentation/ZYBO_RM_B_V6.pdf

4   3



We use now I/O planning (GUI) for pin assignments!

IO planning – pin assignments
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1 2
3

OCTI/O StdPackage Pin

File → Save Constraints or CTRL+S. Then, save the XDC file as:   „lab05.xdc” 



Implementation and Bitstream
generation
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• Flow Navigator menu → Run Implementation

– It can filter out possible wrong assignments / errors,

– Warning messages are allowed (the design can be 

implemented),

– Some floating wires are also allowed (e.g. Peripheral Reset, 

etc.).

– While Vivado is working you can check out the 

synthesis/implementation reports!

Finally, run the Bitstream generation:

• Flow Navigator → Generate Bitstream



• Question-1.) how many resources are occupied on PL?

• Solution: Reports → Report Utilization (or Project

Summary )

Implementation reports
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+----------------------------+------+-------+-----------+-------+
|          Site Type | Used | Fixed | Available | Util% |
+----------------------------+------+-------+-----------+-------+
| Slice LUTs |  691 |     0 |     17600 |  3.93 |
|   LUT as Logic |  629 |     0 |     17600 |  3.57 |
|   LUT as Memory |   62 |     0 |      6000 |  1.03 |
|     LUT as Distributed RAM |    0 |     0 |           |       |
|     LUT as Shift Register |   62 |     0 |           |       |
| Slice Registers | 1010 |     0 |     35200 |  2.87 |
|   Register as Flip Flop | 1010 |     0 |     35200 |  2.87 |



• File → Export → Export Hardware…

VIVADO Export HW → VITIS (~SDK)

38

1

2



VIVADO Export HW → VITIS (cont.)
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Select „Include bitstream” option as output:

2

1



Export HW → VITIS (cont.)
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Set XSA* file name and export directory path:

*Xilinx® Support Archive: new hw descriptor format since VITIS 2020.x (see the next slide)

1

2

3



USING XILINX VITIS
LAB05. Creating a software test application for HC_SR04 IP



1. Creating a Vivado project, then Export HW → VITIS,

2. Creating a new application or an application generated from

a C/C ++ template (e.g. TestSonar as SW application):

a. Importing .XSA

b. Generating and compiling an application project containing a

platform and a domain inside (~BSP: Board Support Package),

c. Generating a Linker Script (specifying memory sections, .LD),

d. Writing / generating and compiling the SW application

3. Creating a ‘Debug Configuration’ for hardware debugging

4. Connecting and setup a JTAG-USB programmer,

– Configuring the FPGA (.BIT hence PL-side was set)

5. Setup a Serial terminal/Console (USB-serial port),

6. Debug (insert breakpoints, stepping, run, etc.)

VITIS – General steps of application
development

42

√



Starting VITIS
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• Set workspace directory properly (lab05):

– Recommended to use vitis_workspace as a  

subdirectory in your lab folder. Launch it...

1

2

OR externally

From Vivado:  Tools menu → Launch VITIS IDE 



Xilinx VITIS – Create Application
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Recall the steps of the former LAB01/LAB02 …

1. Create a new application project

– File → New → Application Project…

2. Platform – Create a new platform from HW (XSA)

– Browse… for LAB05 system_wrapper.xsa.  Open it.

– ! Do not select the „Generate boot components”

3. Application project details

– Type „TestSonar”  as project name

– Type „ TestSonar_system”  as system project name

– Select ps7_cortexa9_0 as target ARM core 0 

4. Domain: leave settings as default (standalone)



• x

Example I.) Creating TestSonar as
empty application

45

1
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VITIS GUI – Main window (HW)
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1

2



Xilinx menu→ SW Repositories

VITIS  – Add Driver Repository

47

2

4

3

1



VITIS – Main window (SW-driver)
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1

2



• Project Explorer → Right Click TestSonar’s → Board

Support Package Settings

VITIS – Set LED_IP driver

49

3

1

2



• Project Explorer → double click on lab5.c → 

Open the Outline → double click on

xparameters.h

(This important header file can be generated after

BSP compiled, and parameter values derived from

Vivado settings)

• #define XPAR_HC_SR04_IP_0_S_AXI_BASEADDR

• This macro defines our „HC_SR04_IP” custom

peripheral

• This #define can be used to read from Ultrasonic

sensor

VITIS – SW project

50



• Path : 
– <lab05_project>\system_wrapper\hw\drivers\

HC_SR04_IP_v1_0\src

• Investigate the content of   .c, and   .h source

files (generated from Vivado tool)!

• Reading from the Ultrasonic Sensor:

HC_SR04_IP drivers

51

#define HC_SR04_IP_mReadReg(BaseAddress, RegOffset) \

Xil_In32((BaseAddress) + (RegOffset))



Analyzing LED_IP application
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• 1.) Read the distance from ultrasonic sensor (in an infinte loop)



*There is a build problem with VITIS 2020.x when creating a custom AXI-lite based IP. 

Makefile generation did not work properly (build error). 

1. Open system_wrapper\ps7_cortexa9_0\standalone_ps7_cortexa9_0\

bsp\ps7_cortexa9_0\libsrc\HC_SR04_IP_v1_0\src\Makefile

2. Modify Makefile

Important Remark* - Makefile

53https://support.xilinx.com/s/question/0D52E00006hpOx5SAE/drivers-and-makefiles-problems-in-vitis-20202

COMPILER=

ARCHIVER=

CP=cp

COMPILER_FLAGS=

EXTRA_COMPILER_FLAGS=

LIB=libxil.a

RELEASEDIR=../../../lib

INCLUDEDIR=../../../include

INCLUDES=-I./. -I${INCLUDEDIR}

INCLUDEFILES=*.h

#LIBSOURCES=*.c
LIBSOURCES=$(wildcard *.c)

#OUTS = *.o

OUTS = $(addsuffix .o, $(basename $(wildcard *.c)))

libs:
echo "Compiling led_ip..."
$(COMPILER) $(COMPILER_FLAGS) $(EXTRA_COMPILER_FLAGS) $(INCLUDES) $(LIBSOURCES)
$(ARCHIVER) -r ${RELEASEDIR}/${LIB} ${OUTS}
make clean

include:

${CP} $(INCLUDEFILES) $(INCLUDEDIR)

clean:
rm -rf ${OUTS}

COMPILER=

ARCHIVER=

CP=cp

COMPILER_FLAGS=

EXTRA_COMPILER_FLAGS=

LIB=libxil.a

RELEASEDIR=../../../lib

INCLUDEDIR=../../../include

INCLUDES=-I./. -I${INCLUDEDIR}

INCLUDEFILES=*.h

#LIBSOURCES=*.c
LIBSOURCES=$(wildcard *.c)

#OUTS = *.o

OUTS = $(addsuffix .o, $(basename $(wildcard *.c)))

libs:
echo "Compiling led_ip..."
$(COMPILER) $(COMPILER_FLAGS) $(EXTRA_COMPILER_FLAGS) $(INCLUDES) $(LIBSOURCES)
$(ARCHIVER) -r ${RELEASEDIR}/${LIB} ${OUTS}
make clean

include:

${CP} $(INCLUDEFILES) $(INCLUDEDIR)

clean:
rm -rf ${OUTS}



• Generate Linker Script to the internal on-chip PS7

RAM0

– Set the Heap / Stack size to 1KB!

– Now rebuild the TestSonar again!

Q: What is the size of Test_Sonar.elf binary?

Generate Linker Script & Build
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'Invoking: ARM v7 Print Size'
arm-none-eabi-size Test_Sonar.elf |tee "Test_Sonar.elf.size"

text   data bss dec    hexfilename
21780   1144   8232  31156 79b4 Test_Sonar.elf

'Finished building: Test_Sonar.elf.size'

'Invoking: ARM v7 Print Size'
arm-none-eabi-size Test_Sonar.elf |tee "Test_Sonar.elf.size"

text   data bss dec    hexfilename
21780   1144   8232  31156 79b4 Test_Sonar.elf

'Finished building: Test_Sonar.elf.size'



TestSonar – Verification result

• Check debug output on VITIS terminal. What did you experience?

lab05 - HC_SR04 Ultrasonic sensor program 

started...

Distance: 191 [cm]

Distance: 191 [cm]

Distance: 191 [cm]

Distance: 2 [cm]

Distance: 6 [cm]

Distance: 2 [cm]

Distance: 2 [cm]

Distance: 4 [cm]

Distance: 5 [cm]

Distance: 9 [cm]

Distance: 9 [cm]

Distance: 11 [cm]……

lab05 - HC_SR04 Ultrasonic sensor program 

started...

Distance: 191 [cm]

Distance: 191 [cm]

Distance: 191 [cm]

Distance: 2 [cm]

Distance: 6 [cm]

Distance: 2 [cm]

Distance: 2 [cm]

Distance: 4 [cm]

Distance: 5 [cm]

Distance: 9 [cm]

Distance: 9 [cm]

Distance: 11 [cm]……
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