
Created by Zsolt Voroshazi, PhD
voroshazi.zsolt@mik.uni-pannon.hu 

EFOP-3.4.3-16-2016-00009

A felsőfokú oktatás minőségének és hozzáférhetőségének 
együttes javítása a Pannon Egyetemen

Updated: 18 Apr. 2024. 

FPGA-BASED EMBEDDED
SYSTEM DEVELOPMENT

(VEMIVIB334BR)



7. VIVADO – EMBEDDED SYSTEM
Creating custom peripherals to BSB #3 (MyLED Peripheral)



1. Introduction – Embedded Systems

2. FPGAs, Digilent ZyBo development platform

3. Embedded System - Firmware development environment (Xilinx Vivado – „EDK” 

Embedded Development)

4. Embedded System - Software development environment (Xilinx VITIS – „SDK”)

5. Embedded Base System Build (and Board Bring-Up) 

6. Adding Peripherals (from IP database) to BSB

7. Creating and adding custom (MyLED) Peripherals to BSB

8. Development, testing and debugging of software applications – Xilinx VITIS (SDK)

9. Design and Development of Complex IP cores and applications (e.g. camera/video/ 

audio controllers)

Topics covered
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• Make sure that the path of the Vivado/VITIS project to be

created does NOT contain accented letters or "White-space"

characters!

• Have permissions on the drive you are working on:

– If possible, DO NOT work on a network / USB drive!

• The name of the project and source files should NOT start with

a number, but they can contain a number! (due to VHDL)

• Use case-sensitive letters consistently in source file and

project!

• If possible, the name of the project directory, project and

source file(s) should be different and refer to their function for

easier identification of error messages.

• The directory path should be no longer than 256 characters!

Important notes & Tips

4



XILINX VIVADO DESIGN SUITE
Creating custom IP core to the Embedded Base System



• Vivado – Block Designer

– Create and add a custom MyLED IP peripheral to

the block design (Embedded Base System) not in

the IP Catalog,

– Parameterize IP blocks, set connections, interfaces,

address, and external ports (if needed),

• VITIS - SDK

– Create SW driver

– Customize compiler settings,

– Creating a software application: LEDWrite ()

Task
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• Create a new project based on previous lab (LAB02_A) by

using the Xilinx Vivado (IPI) embedded system designer,

– LAB02_A project → Save as… → LAB03 !

• Create and generate custom IP Peripheral in Package IP Wizard,

• Select and add custom IP Peripheral to the base system,

• Parameterize and connect them, make external ports,

• Overview of the created project,

– Implementation and Bitstream generation (.BIT) is now necessary,

because PL side will also be configured!

• Create peripheral software application(s) running on ARM by

using the Xilinx VITIS environment (~SDK),

• Verify the operation of the completed embedded system and

software application test on Digilent ZyBo.

Main steps to solve the task
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• Start Vivado

– Start menu → Programs → Xilinx Design Tools → Vivado

2020.1

• Open the previous project! (LAB02_A)

– File → Project → Open… / Open Recent…

– <projectdir>/LAB02_A/<system_name>.xpr →

Open

• File → Project → Save As… → LAB03

– (This will save the former project LAB02_A as LAB03)

Project – Open / Save as…
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PS side:

• ARM hard-processor (Core0)

• Internal OnChip-RAM controller

• UART1 (serial) interface

• External DDR3 memory controller

Test system to be implemented
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PL side (in FPGA logic) 

• LAB03: custom MyLED IP
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Add IP path
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• File → IP →  New Location... → Next
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• Tools → Create and Package New IP… → Next

IP Wizard – LED IP peripheral (I.)
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AXI interfész Little-Endian, hagyományos formátumot 
definiál!

* IP neve: csak 
kisbetűs legyen!!



IP Wizard – LED IP peripheral (II.)
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= Edit in IP Packager…



Project Manager – Package IP template
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Hierarchy (design sources): 

• led_ip_v1_0.vhd (top-level wrapper = „ interface
logic” template)
– led_ip_v1_0_S_AXI.vhd (user-logic =„R/W 

register template”)
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XPR: the generated IP peripheral can be opened as a separate Vivado project (edit_led_ip_v1_0.xpr)

IP-XACT: component.xml     descriptor

• HDL source -

– <ip_proj_dir>/ip_repository/ ip_repo/led_ip_1.0/hdl

• top entity : led_ip_v1_0.vhd

• user logic : led_ip_v1_0_S_AXI.vhd

• BD – Block Diagram -

– <ip_proj_dir>/ip_repository / ip_repo/ led_ip_1.0/ bd

• bd.tcl

• XGUI

– <ip_proj_dir>/ip_repository / ip_repo/ led_ip_1.0/ xgui

• Example design

– <ip_proj_dir>/ip_repository / ip_repo/ led_ip_1.0/ example designs

• /Bfm_design : Bus Functional Simulation sources

• debug_hw_design :

• Driver

– <ip_proj_dir>/ip_repository / ip_repo/ led_ip_1.0/ drivers / led_ip_v1_0/src

• makefile : Makefile

• header : led_ip.h

• source : led_ip.c

• selftest : led_ip_selftest.c

• Driver interface 

– <ip_proj_dir>/ip_repository / ip_repo/ led_ip_1.0/ drivers / led_ip_v1_0/ data

• mdd : led_ip.mdd

• tcl : led_ip_v2_1_0.tcl

Generated components of IP peripheral
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led_ip_v1_0

FW sources

SW source, 

drivers



Generate IP peripheral – IP Catalog
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NOTE: IP-XACT is a standard xml-based descriptor (component.xml) that contains definitions, macros,
descriptors of custom, reusable, pluggable IPs that can be integrated into an electronic circuit system - in our
case an embedded system.



• Open the „top-level” led_ip_v1_0.vhd

• Add the following lines to the file:

Modify peripheral template I. - HDLs
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Finally (CTRL+S or Save)
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• Open „sub-level”   led_ip_v1_0_S_AXI.vhd-t (in the „user-logic”)

• Add the following lines to the file: :

Modify peripheral template II. - HDLs
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Finally (CTRL+S or Save)



Synthesis – Package IP
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• Flow Navigator menu → Run Synthesis (*Save before!)

– Open Synthesized IP peripheral design, OK

– Warning messages are allowed (the design can be 

implemented),

– (Here you can simulate the behaviour of your IP periphery).

Project Manager → Edit Package IP:

• Open   led_ip



Package IP – Customization Parameters
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Package IP – Customization GUI
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Finally: Click on „Review and Package”
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Package IP – Review and Package
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Remember where the 
"led_ip" project was generated

1

2

3

5.) OK.
Finally Re-Package IP.   → YES 
(IP project will automatically close)

4
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• Open project  → Choose „LAB03”

– Project Manager → Settings

– Select IP → + → Add IP path

Return to LAB03
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New IP core can be added in Vivado (two options):

a.) Block Diagram View→ Add IP

b.) Open IP Catalog -> Select IP→ Double-click→ Add IP to Block Design

Add your own LED_IP peripheral on the PL side to the BSB

Adding and connecting PL side 
LED_IP to the base system I.
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Now, for your own IP module (LED_IP) you need to

configure the following in Vivado (can be manual /

automatic!):

– a.) interface connection between IP module and bus

system (AXI),

– b.) assignment of the IP module to an address range (Base-

High Addresses),

– c.) assigning I/O ports of IP modules to external ports,

– d.) finally, assigning external ports to physical FPGA pins

(.XDC editing) - IO planning.

Adding and connecting PL side 
LED_IP to the base system II.
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Double-click on led_ip_0 and examine its parameters.

Block diagram
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Parameterising of LED_IP
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Connect LED_IP
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Completed block design
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• Block Design→ Select „Address Editor”

• Assign the unmapped IP peripheral into the memory address:

– a.) automatically – address generation vs. b.) manually (now)

LED_IP – configure memory address
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*Address ranges must be aligned into 2^n size

and cannet be overlapped! 



led_ip_0 must be connected to the FPGA pins on the ZyBo card:

1.) The data ports of the LED_IP instance must be connected to the external physical FPGA pins,

2.) If necessary, define the names of the external ports (e.g. led_pin), then

3.) In the <system>.XDC file, the pin of the FPGA must be specified.

LED_IP – Assign external ports
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• Refresh the Block Design:

– Regenerate Layout

– Validate Design (DRC)

– Flow Navigator → Run Synthesis

• Then - Open Synthesized Design , OK

• Final step, assign led_pin<3:0> to FPGA IO pins!

– Layout menu -> IO planning layout view

Block Design – Layout synthesis
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We use now I/O planning (GUI) for pin assignments!

IO planning – pin assignments
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3

OCTI/O StdPackage Pin

? ? ?

File → Save Constraints or CTRL+S. Then, save the XDC file as:   „lab03.xdc” 

OCTIO StdSite

Anode(+) Cathode(-)

Common
Cathodes



Implementation and Bitstream
generation
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• Flow Navigator menu → Run Implementation

– It can filter out possible wrong assignments / errors,

– Warning messages are allowed (the design can be 

implemented),

– Some floating wires are also allowed (e.g. Peripheral Reset, 

etc.).

– While Vivado is working you can check out the 

synthesis/implementation reports!

Finally, run the Bitstream generation:

• Flow Navigator → Generate Bitstream



• Question-1.) how many resources are occupied on PL?

• Solution: Reports → Report Utilization (or Project

Summary )

Implementation reports
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+----------------------------+------+-------+-----------+-------+
|          Site Type | Used | Fixed | Available | Util% |
+----------------------------+------+-------+-----------+-------+
| Slice LUTs |  673 |     0 |     17600 |  3.82 |
|   LUT as Logic |  611 |     0 |     17600 |  3.47 |
|   LUT as Memory |   62 |     0 |      6000 |  1.03 |
|     LUT as Shift Register |   62 |     0 |           |       |
| Slice Registers |  994 |     0 |     35200 |  2.82 |
|   Register as Flip Flop |  994 |     0 |     35200 |  2.82 |
+----------------------------+------+-------+-----------+-------+



• File → Export → Export Hardware…

VIVADO Export HW → VITIS (~SDK)
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VIVADO Export HW → VITIS (cont.)
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Select „Include bitstream” option as output:

2

1



Export HW → VITIS (cont.)
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Set XSA* file name and export directory path:

*Xilinx® Support Archive: new hw descriptor format since VITIS 2020.x (see the next slide)

1

2

3



USING XILINX VITIS
LAB03. Creating a software test application for MyLED IP



1. Creating a Vivado project, then Export HW → VITIS,

2. Creating a new application or an application generated from

a C/C ++ template (e.g. MyLEDApp as system monitor test):

a. Importing .XSA

b. Generating and compiling an application project containing a

platform and a domain inside (~BSP: Board Support Package),

c. Generating a Linker Script (specifying memory sections, .LD),

d. Writing / generating and compiling the SW application

3. Creating a ‘Debug Configuration’ for hardware debugging

4. Connecting and setup a JTAG-USB programmer,

– Configuring the FPGA (.BIT hence PL-side was set)

5. Setup a Serial terminal/Console (USB-serial port),

6. Debug (insert breakpoints, stepping, run, etc.)

VITIS – General steps of application
development
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√



Starting VITIS
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• Set workspace directory properly (lab03):

– Recommended to use vitis_workspace as a  

subdirectory in your lab folder. Launch it...

1

2

OR externally

From Vivado:  Tools menu → Launch VITIS IDE 



Xilinx VITIS – Create Application
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Recall the steps of the former LAB01/LAB02 …

1. Create a new application project

– File → New → Application Project…

2. Platform – Create a new platform from HW (XSA)

– Browse… for LAB03  system_wrapper.xsa.  Open it.

– ! Do not select the „Generate boot components”

3. Application project details

– Type „MyLEDApp”  as project name

– Type „MyLEDApp_system”  as system project name

– Select ps7_cortexa9_0 as target ARM core 0 

4. Domain: leave settings as default (standalone)



• x

Example I.) Creating MyLEDApp as
empty application
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VITIS GUI – Main window (HW)
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Xilinx menu→ SW Repositories

VITIS  – Add Driver Repository
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VITIS – Main window (SW-driver)
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• Project Explorer → Right Click MyLEDApp’s → Board

Support Package Settings

VITIS – Set LED_IP driver
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• Project Explorer → double click on

lab3_led_ip.c → Open the Outline → double

click on xparameters.h

(This important header file can be generated after

BSP compiled, and parameter values derived from

Vivado settings)

• #define XPAR_LED_IP_0_DEVICE_ID 0  

This macro defines our „LED_IP” custom peripheral

• This #define can be used to write to LEDs

VITIS – SW project
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• Path : 
– <lab03_project>\system_wrapper\hw\drivers\

led_ip_v1_0\src

• Investigate the content of   .c, and   .h source

files (generated from Vivado tool)!

• Writing to the LED:

LED_IP drivers
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#define LED_IP_mWriteReg(BaseAddress, RegOffset, Data) \

Xil_Out32((BaseAddress) + (RegOffset), (u32)(Data))



Analyzing LED_IP application
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• 1.) Read the actual state of dip switches (in an infinte loop)

• 2.) Write the value of dip switches on our LED_IP



*There is a build problem with VITIS 2020.x when creating a custom AXI-lite based IP. 

Makefile generation did not work properly (build error). 

1. Open system_wrapper\ps7_cortexa9_0\standalone_ps7_cortexa9_0\

bsp\ps7_cortexa9_0\libsrc\led_ip_v1_0\src\Makefile

2. Modify Makefile

Important Remark* - Makefile

50https://support.xilinx.com/s/question/0D52E00006hpOx5SAE/drivers-and-makefiles-problems-in-vitis-20202

COMPILER=

ARCHIVER=

CP=cp

COMPILER_FLAGS=

EXTRA_COMPILER_FLAGS=

LIB=libxil.a

RELEASEDIR=../../../lib

INCLUDEDIR=../../../include

INCLUDES=-I./. -I${INCLUDEDIR}

INCLUDEFILES=*.h

#LIBSOURCES=*.c
LIBSOURCES=$(wildcard *.c)

#OUTS = *.o

OUTS = $(addsuffix .o, $(basename $(wildcard *.c)))

libs:
echo "Compiling led_ip..."
$(COMPILER) $(COMPILER_FLAGS) $(EXTRA_COMPILER_FLAGS) $(INCLUDES) $(LIBSOURCES)
$(ARCHIVER) -r ${RELEASEDIR}/${LIB} ${OUTS}
make clean

include:

${CP} $(INCLUDEFILES) $(INCLUDEDIR)

clean:
rm -rf ${OUTS}



• Generate Linker Script to the internal on-chip PS7

RAM0

– Set the Heap / Stack size to 1KB!

– Now rebuild the MyLEDApp again!

Q: What is the size of MyLEDApp.elf binary?

Generate Linker Script & Build
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'Invoking: ARM v7 Print Size'
arm-none-eabi-size MyLEDApp.elf |tee "MyLEDApp.elf.size"

text   data bss dec    hexfilename
23368   1176   8248  32792 8018 MyLEDApp.elf

'Finished building: MyLEDApp.elf.size'



MyLEDApp – Verification result

• Check debug output on VITIS terminal. What did you experience?

Connected to COMX at 115200

-- Start of the Lab03 LedIP Program --

Dip Switches initialized successfully!

Push Buttons initialized successfully!

State of Dip switches 15!

State of Dip switches 0!

State of Dip switches 3!

State of Dip switches 0!

State of Dip switches 3!

State of Dip switches 4!

……
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• To the ARM-AXI based system created in the previous (5. –

LAB02_A), here we designed and added a new PL-side custom

LED IP peripheral, which is not part of the Vivado IP Catalog.

• Peripheral were properly configured to the BSB and connected

to the external I/O pins of the FPGA.

• We examined both the Block Diagram and the report files.

• Finally, we verified the completed embedded system

(HW+FW) and the correct operation of a SW application

(MyLEDApp) in VITIS unified environment.

LAB03 – Summary
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• Create a Calculator SW application project (CalcTest)

• Modify the previous MyLEDApp SW application to implement

a calculator capable of 4 basic operations.

– Two operands (A,B) will be 2-2 bits, each: A[1:0], B[1:0], which are the

values of the dip switches (dip).

– The following operations can be performed using pushbuttons (pb):

• pb[2:0] = "000" : addition,

• pb[2:0] = "001" : subtraction,

• pb[2:0] = "010" : multiplication,

• pb[2:0] = "011" : division.

• pb[2:0] = "100" : exit

– Display the results of these operations - with only the integer part of

the division - on MyLED[3:0] (also with xprintf())

Task – Calculator test
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CalcTest – Verification result
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• Check debug output on VITIS terminal. What did you experience?

Calculator Program --

Dip Switches initialized successfully!

Push Buttons initialized successfully!

Note: Addition       [+]: PB[2:0]=000

Subtraction [-]: PB[2:0]=001

Multiplication [*]: PB[2:0]=010

Division [/]: PB[2:0]=011

Exit : PB[2:0]=100

-------------------------------------------------

Initial value of result = 0

Partial result after addition 3 + 3 = 6

Partial result after subtraction 3 - 3 = 0

Partial result after multiplication 3 * 3 = 9

Partial result after division 3 / 3 = 1

Partial result after addition 2 + 3 = 5

Partial result after subtraction 2 - 3 = -1

Partial result after multiplication 2 * 3 = 6

Partial result after division 2 / 3 = 0

Exiting from Lab3a calculator!
…

BER_lab3a_calc_vaz
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